Support » Plugin: Video PopUp » No autoplay

  • Resolved johnegg

    (@johnegg)


    Hi guys

    Great plugin but I cant seem to get autoplay to work. Tried adding class vp-a but no good

    John

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Alobaidi

    (@alobaidi)

    Hi,

    Thank you for using our plugin!

    Some browsers have changed the autoplay policy. Some browsers do not support autoplay at the current time, such as Google Chrome, but autoplay still works with Firefox and Microsoft Explorer. Note: Autoplay with MP4 Video is still works good in Google Chrome.

    Best Regards,
    Alobaidi.

    Autoplay for soundcloud (via the embed code from soundcloud.com) still works in chrome but not in this plugin.

    If you replace:
    <iframe src="https://MYWEBSITE.COM/?vp_soundcloud=https://soundcloud.com/MYSOUNDCLOUDACCOUNT/EPISODENAME&auto_play=true" allowfullscreen="" allow="autoplay"></iframe>
    with:
    <iframe allow="autoplay" src="https://w.soundcloud.com/player/?url=https://soundcloud.com/MYSOUNDCLOUDACCOUNT/EPISODENAME&auto_play=true"></iframe>
    It works.

    To that end replace line 137 in /js/YouTubePopUp.jquery.js with:
    var iframe_element = '<iframe allow="autoplay" src="'+data_embed_sc+'" allowfullscreen></iframe>';

    and line 137 in /features/shortcode.php with:
    $embed_sc_url = 'https://w.soundcloud.com/player/?url=' . $atts["url"] . $sc_auto;

    and line 129 in /features/shortcode.php with:
    $sc_auto = '&auto_play=true';

    Note to people who aren’t the plugin developer: If you’re making the above changes you’ll likely need to rename the video-popup plugin folder and then re-enable the plugin as the .js file above seemed to be cached otherwise and your changes won’t take effect.

    • This reply was modified 2 days, 1 hour ago by  btees.
Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.