Support » Theme: Olsen Light » No automatic excerpt

  • It’s possible to change the “Automatically generated excerpt length” for the theme, but this option does nothing. There is always the full article visible on startpage or in categories.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Hello.

    Thank you for bringing this to our attention. This option should not be there. Automatic excerpts are only used on certain templates of the PRO version of the theme. It will be removed in the next version of Olsen Light.

    If you want to restrict what appears on your post listing page you can use the built in “more” tag of WordPress. Info on how to use it can be found here.

    I have the same problem. I research themes and did my homework so I expected excerpt. It is on the demo. http://www.cssigniter.com/demo2/?theme=olsenlight I found out just on the forum that “this option should not be there”.
    It is false promise!
    I am not interested in using “more” tag because my blog is already up and running with feauture pictures. I would have to go through all my posts to change everything :(. Plus, it shows “read more” on the full posts. It mistaken my readers. I just wanted different appearance. When I found Olsen Light theme I was happy because I liked it. Now I am deeply dissapointed!

    Hi there,
    v1.0.2 (available immediately) actually adds an option to control whether the content or the excerpt will be displayed.

    What is v1.0.2 and how can I get it? I will change my review about the theme as soon as I will get it!

    It’s a theme update that you should be able to see through Dashboard > Updates. You may need to press the “Check Again” button to force WordPress to re-check for updates.

    Where in the dashboard can I access the option to have a an excerpt for each post?

    appearance – customize – layout options – [ ] Display the excerpt instead of the content

    Thanks Michael!

    But now it removed the image for the post…it looks like inserting the read more line when writing the post might be best.
    Anyone know of any other ways to automatically create an excerpt without losing the image?

    Thanks!

    Hello.
    This most likely happens because you haven’t set any featured images to your posts. If the image is pasted in the content editor the automatic excerpt will strip it out, if you set it as a featured image, it will appear above the text.

    The problem is when I add my featured image its gets cut off and only a part of the image shows for me. If I add a photo in the text box and a featured image, both show up in the post.

    The post featured image has a predefined size of 665x435px if your images are larger than this they will indeed be cropped.
    If you want a certain image along with text to appear on the listing but don’t want to use the featured image you can paste everything in the excerpt box below the main text editor.

    I’ve been missing that “Display the excerpt instead of the content” checkbox and banging my head this whole time! Thanks for your help Michael!!!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘No automatic excerpt’ is closed to new replies.