Support » Plugin: Simple Google Map » No API warning

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Glenn Welser

    (@gwelser)

    Hi there. Can you confirm that you have entered the Google Maps API key in WordPress admin on the Settings > Simple Google Map page?

    Thread Starter sysygy11

    (@sysygy11)

    Yes, the API is entered in the Settings for SGM.

    Plugin Author Glenn Welser

    (@gwelser)

    Ok great. Can you confirm that billing is enabled for the API key? You’ll have to log in to the Google Cloud Platform Console at https://console.cloud.google.com/project/_/billing/enable to check.

    Thread Starter sysygy11

    (@sysygy11)

    Yes, the API has billing enabled. The API works fine with a different google map plugin with no issues. When I put the same API in with SGM I now get the following 2 errors:
    You have exceeded your request quota for this API. See https://developers.google.com/maps/documentation/javascript/error-messages?utm_source=maps_js&utm_medium=degraded&utm_campaign=billing#api-key-and-billing-errors
    js:51:110

    Google Maps JavaScript API warning: NoApiKeys https://developers.google.com/maps/documentation/javascript/error-messages#no-api-keys

    I do not get these errors using a different google map plugin with the same API. I really want to use SGM because of the simplicity and use of Lat and Long.

    Thanks for your help.

    Plugin Author Glenn Welser

    (@gwelser)

    When I view the source for the page on which you’re using SGM, I do not see your API key in the call to Google Maps. What I guess is happening, is that the Google Maps Javascript file is being enqueued by the other map plugin before SGM can enqueue it with the API Key. Can you try disabling the other map plugin and see if SGM is working then or if the API key is in the source?

    Thread Starter sysygy11

    (@sysygy11)

    Thank you for your help. It turns out that a simple little update to a contact form maker plugin was misbehaving. Once disabled, the maps are now working properly. Weird how stuff like that happens. Thanks again for all of your time and assistance.

    Plugin Author Glenn Welser

    (@gwelser)

    Glad you were able to track down the issue! Can you tell which contact form maker plugin you were using? I may be able to determine why it was interfering with SGM.

    Thread Starter sysygy11

    (@sysygy11)

    The plugin is the Contact Form by WD version 1.13.1 Author is WebDorado Form Builder Team. Thanks for all of your help.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘No API warning’ is closed to new replies.