Support » Plugin: Challonge » No API Key! Set one.

  • Resolved samueldyoung

    (@samueldyoung)


    Hi,

    I have been using the Challonge plugin for a while on my website, and it works great in shortcode.

    I have been getting the ‘No API Key! Set one.’ error for while and would love some help fixing it. I have been reading over previous support questions regarding API issues and haven’t found one that fixes mine.

    I have tried inserting (ini_set(‘display_errors’, true);) above require_once, enabled cUrl and removed http.

    I am running WordPress version 4.5.3.

    Thanks,
    Sam

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author zavaboy

    (@zavaboy)

    That is a bit odd. :/

    Please double-check your API key in your settings and make sure it matches your current API key on your Challonge account exactly.

    The API key input field has validation on it. What does it say when your API key is entered?

    Try clearing the API key, saving, then entering it again. I don’t expect that to fix the issue, but it’s worth a try.

    Another suggestion would be to generate a new API key on Challonge and see if that works.

    Sorry for the inconvenience this is causing. Thanks for the feedback and I hope I’ve been some help. 🙂

    Thanks for the timely reply!

    I double checked the API in the settings and they matched, cleared the API and saved and also generated a new API.
    Unfortunately, that didn’t fix it.

    The weird thing is, I recently migrated my website to AWS and now it works just fine!
    Not sure what was going on, but it seems to have fixed itself!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘No API Key! Set one.’ is closed to new replies.