WordPress.org

Support

Support » Installation » [Resolved] No admin toolbar on website page after upgrade to 3.3.

[Resolved] No admin toolbar on website page after upgrade to 3.3.

  • Hi, hope this is not a duplicate thread but I’m not having exactly the problem that most are having with upgrades.
    After upgrading to 3.3, I can see and use my admin/dashboard page fine but when I go to the site after logging in to the admin page, don’t have the admin toolbar like I used too. Instead I get this ;
    Warning: Invalid argument supplied for foreach() in /[abridged address]/wp-includes/class-wp-admin-bar.php on line 342

    Any thoughts?

    thanks

Viewing 15 replies - 1 through 15 (of 22 total)
  • probably a theme problem, try changing theme and see if it works with the deafualt one for example. that should point you in the right direcion.

    I got an error that starts

    Fatal error: Call to undefined method Custom_Admin_Bar::add_group() [name of site here] wp-includes/admin-bar.php on line 169

    Anyway I switched themes and it is a theme issue which I will have to have a look at

    @casedimage have tried switching theme to default theme

    Yes when I change themes the toolbar comes back. The design of the rest of my website (casedimage.com) is based around this theme – Wooden Mannequin 1.1.

    I did find this article –
    http://voodoopress.com/wordpress-3-1-admin-bar-upgrade-issues/

    The header/footer solutions didn’t work which is not surprising given the error is in the class-wp-admin-bar.php. But it did give me a solution – to remove the admin toolbar when viewing the site, through editing my options on my user profile. I never used the toolbar from the site anyway but it was handy to see the stats there. Them’s the breaks!

    Thanks all for your help.

    Tagged the post for the theme, but it’s not been updated in years, so you may be out of luck there 🙁

    I’m having this issue as well. What theme are you guys using? I’m using a modification of Arthemia.

    As stated, they’re using Wooden Mannequin.

    Try switching to an UN modified version of your theme and see if it’s your changes. If not, please make a NEW topic for yourself so we can track down theme issues there. 🙂

    Removing “<?php wp_footer(); ?>” from footer.php of your custom template will remove the Line 342 error and show the admin bar; however, it may prove problematic for anything that requires “<?php wp_footer(); ?>” to function properly.

    I’m having issues on a bunch of my wordpress sites.

    Fatal error: Call to undefined method Custom_Admin_Bar::add_group() in /home/content/07/4012107/html/wp-includes/admin-bar.php on line 169

    Is showing up in the footer on all sites after the upgrades.

    Same issue. I’m not seeing any errors though. I’ve also tried switching to TwentyTen and TwentyEleven with no success. I do see a space at the top where it should be, but not bar.

    lonestarseo: interesting … My site (happythursday.com) is using a slightly modified Wooden Mannequin v1.1 theme running on WP3.3 and I’ve not had an issue with errors or a missing Admin bar. My theme still retains the original PHP in footer.php. It reads somewhat different from what you post, though. Mine is:

    <?php do_action('wp_footer'); ?>

    Having same issue as TakeTheCannOlis. No errors. No success when switching themes. No toolbar.

    After tinkering for a little bit, I realized that WP Super Cache was causing the issue with Twenty-10 and Twenty-11. I disabled the plugin but still had problems with the other themes that I’ve used. WP Anniversary is my standard theme. I posted on their forum.

    So, is there an actual resolution to this issue other than removing the footer of our theme?

    Update… I added <?php wp_footer() ?> to the very end of my footer right before the closing body tag and now I have my toolbar back.

    Try it out

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[Resolved] No admin toolbar on website page after upgrade to 3.3.’ is closed to new replies.