WordPress.org

Support

Support » Installation » No admin panel after login

No admin panel after login

Viewing 13 replies - 1 through 13 (of 13 total)
  • ChristiNi

    @christini

    Hi Beeeater,

    Sounds like your WordPress site didn’t install quite correctly. Do you see your WordPress site when you go to your domain name? Double check the folder where you installed WordPress and check your Site URL as well:

    http://codex.wordpress.org/Changing_The_Site_URL

    Feel free to provide a link to where you installed WordPress.

    Hope this helps!

    Beeeater

    @beeeater

    Reading the installation instructions carefully, I realised that I had not placed the wordpress folder in the ROOT of my website, but in a subfolder – so i moved it to the root. Now when I log in I get this: The requested URL /blog/wp-login.php was not found on this server.

    ChristiNi

    @christini

    Hi Beeeater,

    Did you update your Site URL after moving your files?

    http://codex.wordpress.org/Changing_The_Site_URL

    Thanks!

    ravimallya

    @ravimallya

    Please provide us with the URL of blog where you installed WordPress and the exact dashboard URL where you’re receiving error. However, please try adding the following in the .htaccess file within the wp-admin directory:

    Options -Indexes
    DirectoryIndex index.php index.html index.htm

    Hope this will fix the problem.

    Beeeater

    @beeeater

    I have tried to remedy the issue by the use of the define(‘RELOCATE’,true); statement in the wp-login.php file. However I still just get a page with a directory listing after login. The page title is Index of /blog/wp-admin and the URL is http://www.synergies.co.za/blog/wp-admin/ -the WordPress files ARE located at this location. It is almost like instead of loading the correct page, it just gives a directory listing.

    I have noticed that if I click on the ‘Back to blog’ link on the login page, it takes me to http://blog.synergies.co.za/blog/, a different URL – Where is WordPress getting this URL from?

    This is becoming very frustrating. Surely there is a simple fix, or else a way to uninstall and start over?

    Beeeater

    @beeeater

    Additionally, there is no .htaccess file within the wp-admin directory.

    Beeeater

    @beeeater

    Also, when I use PHPMyAdmin the site URL is listed as http://www.synergies.co.za/blog which is the correct location.

    ChristiNi

    @christini

    Hi Beeeater,

    It looks like something is not set up correctly on your server or at least in that directory. I see index.php files in both synergies.co.za/blog/ and synergies.co.za/blog/wp-admin/.

    Using either your hosts File Manager or an FTP program, double check for the .htaccess file. It’s a hidden file, so you will need to make sure you have selected the option to view hidden files. If you do have an .htaccess file, open the file and see if you see any reference to DirectoryIndex (followed by a filename). If you do see that, and the file name after it is anything other than index.php, remove that line.

    It really looks like something is going on with that site URL. You should double check your wp-config.php file and functions.php to see if the site url has been changed in either of those files. Additionally, if you have set the site url correctly in the database:

    Also, when I use PHPMyAdmin the site URL is listed as http://www.synergies.co.za/blog which is the correct location.

    You do NOT need to use any of the other methods for changing the site URL. The Relocate Method is not needed so you will want to remove that. Have you confirmed that both the siteurl and home fields in your database are set to http://www.synergies.co.za/blog?

    Hope this helps!

    Beeeater

    @beeeater

    Hi ChristiNi,

    This is really getting frustrating! I decided to start again from scratch – I dropped all the tables from the MySQL database, in fact I created a NEW database, deleted all the existing wordpress files from the ‘blog’ folder on my website, edited a brand new wp-config.php with all the new database values, uploaded the wordpress folder after renaming it ‘wordpressblog’, ran install.php successfully and then tried to log in. Guess what? Exactly the same issue! Now I get a directory listing titled ‘Index of /wordpressblog/wp-admin’ and the page URL is ‘http://www.synergies.co.za/wordpressblog/wp-admin/’
    There is an .htaccess file in the root of my webserver, the contents of which look something like this:

    # -FrontPage-
    IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*
    <Limit GET POST>
    order deny,allow
    deny from all
    allow from all
    </Limit>
    <Limit PUT DELETE>
    order deny,allow
    deny from all
    </Limit>
    AuthName synergies.co.za
    AuthUserFile /usr/www/users/synergv/_vti_pvt/service.pwd
    AuthGroupFile /usr/www/users/synergv/_vti_pvt/service.grp
    DirectoryIndex index.html

    I have a feeling this could be causing the problem, but I have no idea how to change it.

    Any ideas?

    ChristiNi

    @christini

    Hi Beeeater,

    I suspect the issue is that last line:

    DirectoryIndex index.html

    .htaccess files are recursive, which means it can affect child subfolders. WordPress doesn’t create .htaccess in it’s folder until you add or change permalinks.

    To fix this, change that last line in that .htaccess file to:

    DirectoryIndex index.html index.php

    Let me know if that works!

    when i login our admin panel ,it did not show anything and no any error message give.
    but my site working properly
    sir/madam … please help me …i am frustrated.

    @avi123 First check the file permission of the folder wp-admin and if the issue still persist try by re-uploading the wordpress files…

    format the root folder and then drop the tables, and then install fresh wordpress, it will definitely solve your problem.

    [sig moderated as per the Forum Rules. Also please do not use your username to try and promote your own commercial services. That is not tolerated on these forums.]

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘No admin panel after login’ is closed to new replies.
Skip to toolbar