Support » Installing WordPress » No admin interface after upgrade to 2.6.1.

  • Resolved LostInNetwork


    I have now tried to upgrade from 2.5.1 to 2.6.1. Installatron (in DirectAdmin) didn’t like the quota hard limit, and trashed my wp install. Yes, it did so really effectively.

    PROBLEM: As soon as I get WP 2.5.1 reinstalled and the database restored and the upgrade to 2.6.1 finishes, instead of an admin interface I get this:

    Warning: array_keys() [function.array-keys]: The first argument should be an array in /home/userX/domains/ on line 686

    Warning: Invalid argument supplied for foreach() in /home/userX/domains/ on line 686

    Warning: Cannot modify header information – headers already sent by (output started at /home/userX/domains/ in /home/userX/domains/ on line 770

    Any ideas? Is there something strange in the database? I have tried to look with myphpadmin but don’t find any problems…

Viewing 6 replies - 1 through 6 (of 6 total)
  • Samuel B


    Are you deactivating your plugins?



    All the plugins had been disabled and the default theme was in use.

    After the upgrade
    – these error messages (re)appeared
    – scandinavian characters were replaced with some garbage (two chars)



    If I restore the WordPress files (overwrite using sftp transfer) and then run upgrade.php I can successfully go back to 2.5.1

    The upgrade path seems blocked for now, though.



    The problem seems to be at:

    function wp_widget_text_register() {

    foreach ( array_keys($options) as $o ) {

    I have double quotes and HTML code in my text widgets (to insert images etc). Could this cause some trouble while reading the options, even if the text widget would not be in use?




    I commented out line 1428 of wp-includes/widgets.php:
    // wp_widget_text_register();

    Now my site functions – with two exceptions.
    – no text widgets
    – scandinavian characters are still replaced with garbage.


    1) so, what is wrong with my text widgets? This error happens even with all the plugins disabled and the default theme as active. I suspect that there is something invalid in the options table (for text widgets) in my database. How can I correct that? What is the correct format? Can I just empty that field in phpMyAdmin?

    2) How do I get these å, ä, ö back? More specifically, I want to do this correction:
    ä -> ä
    ö -> ö

    Thank you




    The admin interface had UTF-8 setting and wp-config.php had utf8. I changed these to match, i.e. they are now both UTF-8 and now the characters are displayed correctly.

    I also enabled wp_widget_text_register(); AFTER
    – upgrade to 2.6.1
    – deleting unused themes
    – deleting left behind tables (of long since uninstalled plugins)
    – deleting unused wp_options records, that once were used by long gone plugins
    – running Repair DB of WP-DBManager plugin

    Something happened, and the problem is gone.

    ps. WP-DBManager saved me about twenty times yesterday, as I was attempting various ways to solve this issue. What a great plugin! Very much recommended 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘No admin interface after upgrade to 2.6.1.’ is closed to new replies.