[resolved] No Add to cart with variable products (14 posts)

  1. rboulet
    Posted 2 years ago #

    I'm also missing 'add to cart' buttons on my site. Latest version of WooC & WP.

    Using yer basic 2013 theme.

    The 'clear selection' link also does not work.

    any ideas? Thanks!


  2. rboulet
    Posted 2 years ago #

    Updated WooC & still using the 2013 theme. Still can't get the Add to Cart button to show after making variable selections. Still can't get the 'clear selection' link to work as well.

    Thanks for the assist anyone!

  3. scotthomer6
    Posted 2 years ago #

    Having the exact same problem myself. Am yet to find anyone that has solved the issue though!

    The problem appears even with the most basic site using woocommerce as the only activated plugin meaning there are no plugin conflicts. This problem also is present no matter what theme i use. So there is no theme conflict either.

    I'm confused too.

  4. rboulet
    Posted 2 years ago #

    FYI, I tried the solution from an earlier post:


    This still did not resolve things. (on a shared platform, so I used the DIY instructions. Also, the github link for changes the host could make was a 404 not found.)

  5. rboulet
    Posted 2 years ago #

    Ok and now Firebug is telling me the browser isn't using that code yet. I guess I'll walk away for now & see if a little flush does the trick

  6. supawiz6991
    Posted 2 years ago #

    Having this issue with IE only. Im using IE9. I opened the developer tools and i changed my browser mode to IE8 the button shows up. When I switch it back to IE9 and refresh the check out button shows up..

  7. Ruth Maude
    Posted 2 years ago #

    Here's the answer.

    Add this code to your functions file and the Add to cart buttons will appear.

    function mv_my_theme_scripts()
    wp_enqueue_script('add-to-cart-variation', plugins_url() . '/woocommerce/assets/js/frontend/add-to-cart-variation.js',array('jquery'),'1.0',true);
  8. supawiz6991
    Posted 2 years ago #

    I brought the site up on another computer and was able to replicate the issue. I brought up IE's developer tools and opened console and refreshed the page to see if any errors were generated... and after refreshing the add to cart button loaded.

    I'm wondering if something is failing to load when the page first loads.

  9. rboulet
    Posted 2 years ago #

    Hey Ruth!

    I should've mentioned that I tried your solution first, to no avail unfortunately.

  10. Ruth Maude
    Posted 2 years ago #

    I had this problem this morning and this is what I did...

    1. changed theme I was using to default 2013 that didn't fix it
    2. deactivated all plugins except Woo and that didn't fix it
    3. Created a functions.php file in my child theme with the code above wrapped in php tags and that worked.

    I just looked on IE and fortunately it's working there for me.

    I hope you find the solution for your IE issue.

  11. tairak
    Posted 2 years ago #

    Ruth your solution worked perfectly. Even in IE.
    Thank you!

    The 'clear selection' link is not working for me either.

  12. rboulet
    Posted 2 years ago #

    Drat. Mine's a plugin conflict. Thanks for the assist... now to figure out which one it is...

  13. rboulet
    Posted 2 years ago #

    Aha! It was the Root Relative plugin that was installed by default by my host. In case anyone else runs into this issue - try turning this off & installing Ruth's code above.

  14. scotthomer6
    Posted 2 years ago #

    Thanks Ruth! That worked great!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WooCommerce
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.