• Resolved timbergski

    (@timbergski)


    Hi,

    No activation emails are being sent, but others are. I’m just starting to use the plugin, on WordPress 5.8.2. I had problems sending emails via the local SMTP server so I installed the WP Mail SMTP plugin and set it to use sparkpost. Test emails work. If I register I get a welcome email (even though I selected activation emails), if I delete the account I get a deletion email. I have ticked the tickbox in Settings->Email->account activation emails, and it’s showing enabled in the list of emails.

    I don’t think it’s about file system permissions because I see no errors in apache’s error log.

    What could be the problem?

    Thanks.

Viewing 5 replies - 1 through 5 (of 5 total)
  • missveronica

    (@missveronicatv)

    @timbergski

    You can install the “Check & Log Email” plugin to log all emails being sent either wp-mail or SMTP. With this plugin you can verify if the Activation email is being sent and lost at an email server or not at all being sent from UM.

    https://wordpress.org/plugins/check-email/

    Thread Starter timbergski

    (@timbergski)

    Thanks for the reply. I should have said that I was already doing that with another plugin that logs emails. For good measure, I installed the one you suggested. It gives the same results: UM sends only the Welcome message plus a notification to me, as administrator, of a new user account. There’s no activation message in the log. The existence of a Welcome message anyway suggests a failure of logic somewhere, rather than an email sending issue.

    missveronica

    (@missveronicatv)

    @timbergski

    Verify that your “Registration Default Role”:

    UM -> Settings -> Registration Form -> Registration Default Role

    and this role’s “Registration Status” is set to “Require Admin Review”:

    UM -> User Roles -> “Registration Default Role” -> Edit -> Registration Options -> Registration Status -> Require Admin Review

    Thread Starter timbergski

    (@timbergski)

    Thanks, I wanted email activation (not admin review) but I set that via the same path. It works now.

    The tickbox in Settings -> Email -> account activation is misleading. I see that the information widget placed by it doesn’t literally say “enable email activation” but unless you stop and read it carefully it seems to imply that. Why I would I want email activation without an activation email?! So I didn’t think I needed to do anything else. Is there a valid reason for that tickbox? If so, the information widget should clarify that email activation needs to be set up in Roles.

    Timbergski.

    Plugin Contributor Champ Camba

    (@champsupertramp)

    Hi @timbergski

    Thanks for letting us know how it resolved the issue.

    Regards,

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.