Support » Plugin: Gravity Forms Salesforce » No Access to Salesforce API – 2005

  • Resolved Michael

    (@mikegandy)


    I set up the form on my website and it was working fine last week, but suddenly this morning I get an error message saying “No Access to Salesforce API – 2005” and did not add my entry to Salesforce. What does this error mean? I’d like to diagnose the problem. The API is enabled in Salesforce, and I have not made any changes to the website since it was working. Thanks in advance.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author CRM Perks

    (@crmperks)

    there are two reasons
    1= major is multiple connections https://i.imgur.com/P4SbCJD.png
    2=someone may revoke access from salesforce

    Thread Starter Michael

    (@mikegandy)

    Thank you. It appears that it is due to reason #1 since I have 7 sites connected to it. I have created a new app to use and updated the accounts on 2 sites with the “Use Own Salesforce App” selected and filled out. I also updated the forms with the new account and the status shows as good. Do I need to create another app for the remaining 5 sites?

    Thread Starter Michael

    (@mikegandy)

    I am circling back to this as I am also having problems. I created two new apps on Salesforce and updated all websites with one or the other (3 on one, 4 on the other); however, after a couple of entries I still get the errors and have to reconnect. What do you mean by your second reason? Are you meaning Salesforce could revoke access from our account? Or an admin on our account revoking access? I don’t think this is the problem as it let’s me connect as long as go in and manually connect them again. Any other suggestions?

    Plugin Contributor Samer Bazzi

    (@sbazzi)

    Hey @mikegandy,

    I hope all is well. One of our team members will get in touch wuth you shortly.

    Thank You – Sam

    Hi,

    I am getting the exact same error. Does anyone have a solution to this? I am using @crmperks as well.

    Thanks,
    -Mark B

    Thread Starter Michael

    (@mikegandy)

    @smartguyus They had me revoke all connections, then connect the first 4 without any app and the others with my custom app. That worked for me.

    • This reply was modified 2 weeks, 1 day ago by Michael.

    @mikegandy Thanks. Unfortunately it didnt work for me. I emailed thier support.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.