Support » Plugin: Theme My Login » No access to profile or dashboard?

  • Resolved ichadwick

    (@ichadwick)


    Hello Jeff. Nice plugin and it seems to work very well, with one small hiccup.

    I do not want subscribers to have access to the dashboard or profile. I want them to go directly to the home page once they have logged in. So I activated the custom links.

    I then deleted both profile and dashboard links for subscribers and added just a “home” link to the main site. This didn’t work and it continued to load the wp-admin profile page when I tested it. However, when I changed both author and contributor to the same single home link, it worked.

    Just FYI. It doesn’t matter to me right now since I currently don’t use those categories, but may want to in the future.

Viewing 2 replies - 1 through 2 (of 2 total)
  • I take it back. It worked for a while, yesterday, but today when I logged in on an incognito window as a member, it took me right back to the profile window again. I tried logging out and back in – same thing happens every time.

    It seems I also have to set the redirection links. So now it works if I do that, but…

    Is there any way to entirely prevent users from getting to their profile/Jetpack/dashboard?

    PS. The CAPTCHA equation doesn’t always display on the log-in page. Should it?

    • This reply was modified 2 years, 4 months ago by ichadwick.
    Plugin Author Jeff Farthing

    (@jfarthing84)

    You need the Custom Redirection module to change where the user is redirected upon logging in.

    In order to completely disable /wp-admin for specific roles, you can enable the Themed Profiles module and do so in it’s settings.

    Also, TML’s reCAPTCHA only shows on registration.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘No access to profile or dashboard?’ is closed to new replies.