Support » Fixing WordPress » No access to dashboard & site displays homepage only

  • After upgrading to WordPress 4.3 today, I can’t access the dashboard for http://lithuanianmha.org/ (it’s all white) and can’t see any pages other than the homepage (all other pages are white). In fact, I can’t even see the homepage with IE and Chrome — only Firefox.

    I’ve read all of the forum posts I could find, but haven’t found a solution. My theme (Weaver II Pro) is running on the latest version. I tried deleting all themes other than Twenty Fifteen and that did not work. I also changed the .htaccess file to the following code per one forum, but that didn’t make a difference either.

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    Please help! I’d appreciate any advice you can share!

    -Christiana

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi,

    Try following suggestions:

    1) Memory exhaustion

    Memory exhaustion is one of the most common reason behind white screen of death error. To fix this, you will need to increase the memory limit in WordPress. Open wp-config.php file located under WordPress directory, add following line in wp-config.php and save the file.

    define('WP_MEMORY_LIMIT', '128M');

    If you still get this error after above fix, you will have to extend the PHP memory limit from php.ini file. You can also contact your web host to increase the PHP Memory limit.

    2) Try Deactivate All Plugins Through cPanel

    Login at cPanel, Under Files section, Go to File Manager.
    Select Web Root (public_html/www) and click Go.

    Expand the public_html folder, and navigate to the /wp-content/plugins folder.

    Right click on the /wp-content/plugins folder and rename it like plugins.old. This will deactivate all of the plugins at once.

    Now, reactivate plugins folder again by renaming back to plugins. This will allow you to access the WordPress Dashboard again.

    If white screen disappears from your website, activate plugins one by one until the white screen comes back. When it does, you’ll know the culprit plugin.

    Hope that helps.
    Thanks,

    Hello @lithuanianmha,
    You are using WP Super Cache plugin. Sometimes you face problem with Cache. Before doing something take backup of your WordPress file through cPanel and take backup of your database also. Now deactivate WP Super Cache Plugin as @accuwebhosting guide you.

    Now open wp-config.php file and remove below one and save it.

    define('WP_CACHE', true); //Added by WP-Cache Manager
    define( 'WPCACHEHOME', 'E:\xampp\htdocs\testing\wp-content\plugins\wp-super-cache/' ); //Added by WP-Cache Manager

    And Check your .htaccess file. The default .htaccess file-

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    If this one not helps you then download fresh WP and unzip it and upload only wp-admin and wp-includes folder. And repeat the above steps as I guide you early.

    Please let me know the status.

    Hello Accuwebhosting and Bswajitgiri.

    Thank you for sharing your suggestions! I did everything you recommended except,

    If you still get this error after above fix, you will have to extend the PHP memory limit from php.ini file. You can also contact your web host to increase the PHP Memory limit.

    . Also, after deactivating all of the plugins and then reactivating them one by one, I did NOT reactivate WP Super Cache since you warned that it might be the issue and since none of the other plugins seemed to cause the white screen of death error. So far, so good! http://lithuanianmha.org is restored and working!

    Is there any reason that I should be concerned about not using WP Super Cache? Is it necessary?

    Thank you for your help. You both helped to correct a horrible situation!

    -Christiana

    This article was very helpful: https://updraftplus.com/faqs/migrating-site-front-page-works-pages-give-404-error/

    Simply go to your admin panel – Settings – Permalinks – and click ‘Save’. This will create the necessary file on your server, and sub directories should start working agian.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘No access to dashboard & site displays homepage only’ is closed to new replies.