Support » Plugin: Ultimate Member – User Profile, User Registration, Login & Membership Plugin » No Access from Front- to Backend (Author)

  • Resolved nwmbm

    (@nwmbm)


    Hello, after successfully logging in via the login page, I get into baking normally.

    Screenshot: https://i.imgur.com/AUghzXA.png

    When I then want to switch to the frontend, everything works fine.

    Screenshot: https://i.imgur.com/GaFBWpf.png

    But when I try to switch back to the backend, for example to create a post, I get the following error:

    “Unfortunately, you are not authorised to access this page.”

    Screenshot: https://i.imgur.com/hL49guN.png

    That’s strange, because I have granted wp-admin access to the user role.

    Can anyone help me here?

    Thank you very much.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Thread Starter nwmbm

    (@nwmbm)

    Other helpful info:

    https://i.imgur.com/0FlJyCU.png

    Plugin Support Aswin Giri

    (@aswingiri)

    Hello @nwmbm

    Can you please also include a screenshot for Role Setting?

    Thread Starter nwmbm

    (@nwmbm)

    Thread Starter nwmbm

    (@nwmbm)

    I’m not sure right now if we understand each other correctly here. I have already created a template for the login. Actually, I have created all templates as described in your tutorial.

    My problem is that all users except the admin get an error message when they want to go to the dashboard in the frontend. But if you click on the speedometer Icon you get into the backend e.g. as author and can create a post.

    I have recorded the error and saved it as a short video:

    It is not clear to me now why I should now set up a maintenance page, everything works. I just couldn’t get back to the backend via the WordPress “Dashboard” button.

    Many greetings and thanks for your patience.

    Plugin Support Aswin Giri

    (@aswingiri)

    Hello @nwmbm

    If you look carefully, “Dashboard” link is not linked to /wp-admin but admin.php?page=custom-dashboard.php where as icon is linked to /wp-admin

    I believe you do have some plugin or custom code that modifies the Dashboard link URL, please try to disable the plugin/custom code and see if that fixes the issue.

    Thread Starter nwmbm

    (@nwmbm)

    `Hello, thank you, you are right!

    The Site Ground Central plugin is causing this problem. I deactivated the plugin and now it works.

    After consultation with Site Ground Support, this plugin is also basically not needed. It is probably only for inexperienced users so that they can get started more quickly.

    <strong>@Site Ground Clients:</strong> Please deactivate the plugin “Site Ground Central” so that there are no conflicts with Ultimate Members.

    Please close ticket!

    Thanks.

    Plugin Support Ultimate Member Support

    (@ultimatemembersupport)

    Thanks for letting us know how you’ve resolved the issue. I’m marking this topic as resolved now.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.