Support » Plugin: WP Super Cache » No access for Zend OPcache?

  • Resolved whjtefox

    (@whjtefox)


    Hello. Recently I started to see on each page of the plug-in this message:

    “Warning: Zend OPcache API is restricted by “restrict_api” configuration directive in /home/site/mysitename.com/html/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 1099″.

    I turned to the support of my hosting to solve this problem. As a result, they advised to write here – on the forum plug-in. Any thoughts on how to fix this problem?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Fine (sarcasm). The problem resolved itself.

    • This reply was modified 1 year, 3 months ago by  whjtefox.

    Problem still exist in my blog.

    I have this problem too

    AFAIK this is PHP 7.2 compatibility problem.
    Downgrade to PHP 7.1 will eliminate the warning.

    Plugin Author Donncha Ó Caoimh

    (@donncha)

    Your hosting has disabled the opcache_invalidate command that the plugin uses to reload the configuration file after it’s modified. It was a bit cheeky of them to tell you to write here when they knew what caused this.

    We can hide the warning but it might mean that it will look like settings aren’t updated correctly when they actually are. I think this only applies if your using the REST API though.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘No access for Zend OPcache?’ is closed to new replies.