Support » Fixing WordPress » No 404 happening – confirmed with host

  • Hi,

    I’ve been working with my host for the past week to try and diagnose what could be causing 404 errors to not show up. This is what he said:

    Looking closer at your message, there is no 404 happening, because the index.php file does exist. This cannot be fixed via IIS, it must be done inside their application. See this for example:

    I can paste this link if necessary, just didn’t want to spam.

    Given my limited experience with PHP, I don’t know if this is even possible to fix, let alone how to fix it. Does anyone in the community here have any insight on this?


Viewing 7 replies - 1 through 7 (of 7 total)
  • Ummm.. What? You’ll have to be more specific as to what the actual problem is. Posting the host’s answer to the problem is less than helpful.

    The problem that I kept having was that 404 errors were not getting generated. For example, last month I changed my “pretty” permalink structure from:




    I thought that all of the old incoming links with “/archives/” should now generate a 404 error, because they no longer follow the permalink structure. Unfortunately they don’t and that is why I contacted my host. I wanted to make sure that everything on their end was 100% correct, and according to them, it’s a problem with WordPress.

    What’s really weird is that I cannot get a 404 error to generate no matter what address I try.

    None of the above links generate a 404 error page.

    What is the content of the .htaccess file?
    What are the values that you have on the Options->General page for WordPress URL and Blog URL?

    There is no .htaccess, my host is using IIS (yuck!). I know getting a different host running Apache would be the easiest solution for this problem, but it would cause way too many other problems:(

    The same URL is entered for both my WordPress and Blog URL:

    I’ve had the exact same problem and it appears to be how WordPress deals with permalink structure. I went thru this same thing with my host, and found that WordPress enacts some kind of redirect that sends would be 404 errors back to the top directory. In my case my domainname.

    For example:

    I could enter the url: does wordpress always break?

    and get to

    Same problem, no answer.

    – nina

    There is no .htaccess, my host is using IIS (yuck!)

    Well, there’s your problem.

    WordPress’s pretty permalinks absolutely depend upon all traffic getting redirected to the main index.php file. If that doesn’t happen, permalinks fail to function. Since IIS sucks and does not do .htaccess, no pretty permalinks for you.

    Sorry. WordPress “works” with IIS. Just not well.

    I was able to get permalinks to work in IIS, just not as well. I followed the helpful advice from a support page I found a while back:

    Look under, “Using Permalinks Without mod_rewrite”. However, what really sucks is that I just could never get rid of “index.php” in IIS.

    Anyways, that was for anyone reading this thread in the future.

    IIS is great for a lot of things, don’t get me wrong. It just really sucks for times when your host is using it and you want to use an awesome program like WordPress:(

    Oh well, thanks for getting back to me though everyone!

    If anyone else finds an answer to this problem please let all of the community know about it in this thread!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘No 404 happening – confirmed with host’ is closed to new replies.