Support » Plugin: Calendar Event Multi View » nmonth view ignoring maxdate

  • Resolved ruthedmondson

    (@ruthedmondson)


    Great calendar with so many choices of display, perfect for a my new site.
    I have set maxdate:”2019-11-30″ in the Other parameters box for my nmonth (n=12) view. I want the calendar to display only up to the end of November, so 12 should work whatever the current month is. However the calendar is ignoring this setting and showing all 12 months. The other parameter in the box (date_box_with_color_in_nmonth_view:true,) works OK.
    I am running this plugin as a test on an existing wp site that is also running fullcalendar before designing the site this plugin is intended for. Does that matter?
    Thanks

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author codepeople

    (@codepeople)

    Hi,

    To correct that issue please update to the latest plugin version #1.3.84 published today.

    Thank you!

    Thanks, it’s not quite how I thought it would be as:
    1) It now ends at maxdate, but starts n (12 in my case) months before. Presumably I need to set a mindate as well. The problem with that is how can I set a mindate of ‘today’ in the other parameters?
    2) The navigation arrows are still there, despite the ‘next’ arrow being inactive.
    3) Different problem: The language file en-GB is actually en-US. The GB version should be day, month, year not month, day, year (I have changed this in my file).

    Thanks

    Ruth

    Plugin Author codepeople

    (@codepeople)

    Hi,

    Sorry for the late. Please update to the latest version #1.3.85 published today, this will fix the issues described in the points #1 and #2.

    Regarding to #3 please see the solution at the following FAQ entry:

    https://wordpress.dwbooster.com/faq/cp-multi-view-calendar#q137

    Thank you for the feedback!

    Hi

    Thanks for all your help.

    I understand that I can change the mm/dd to dd/mm, I was just trying to say that the en-GB default should be dd/mm and en-US default mm/dd for next time you update the plugin.

    Thanks again

    Ruth

    Plugin Author codepeople

    (@codepeople)

    Hi,

    Please update to the latest plugin version published today, we have added a new feature to overwrite the auto-detected date format. The new settings field is located in the “Troubleshoot Area” located below the list of calendars.

    Location of the new settings field shown in the following image:

    https://wordpress.dwbooster.com/images/mv-calendar/date-format-update.png

    Thank you for your feedback!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘nmonth view ignoring maxdate’ is closed to new replies.