Support » Theme: Nisarg » Nisarg Blog Posts

  • Hello! I am new to WordPress, however I am really enjoying the Nisarg theme for my blog! I would like to see if the blog posts could show in their entirety and if the font could be made smaller.

    I went to Settings>Reading>For Each Article in the Feed: > Full Text but it is still showing what looks like the Summary style.

    Thanks for your help!

Viewing 6 replies - 1 through 6 (of 6 total)
  • Theme Author Falguni


    Hi @mockerbird,

    Sorry for the late reply. You can see blog post entirely by clicking on the blog post link/read more link. But if you want to show the blog post entirely on the post listing page, then you have to make changes in the code. Open content-*.php and remove the following if condition from all content-*.php.

    <?php if ( is_search() || is_home() || is_archive() || is_author()) : // Only display Excerpts for Search ?>
    		    <div class="entry-summary">
    		        <?php the_excerpt(); ?>
    		    </div><!-- .entry-summary -->

    Only keep the code in the else part.Final code to keep is:

    <div class="entry-content">
    					wp_link_pages( array(
    						'before' => '<div class="page-links">' . esc_html__( 'Pages:', 'nisarg' ),
    						'after'  => '</div>',
    					) );
    			</div><!-- .entry-content -->

    To change font size make changes in the style.css file in the following area:

    textarea {
    color: #424242;
    font-size: keep font size whatever you want
    font-weight: 400;
    font-family: ‘Source Sans Pro’, sans-serif;

    Hi. I just recently downloaded your Theme and love it.

    I want to disable the automatic “read more” of the Blog Entries when the Blog loads for Readers. I want to add it manually when I feel it needs to be there.

    What line of code – and on what .php page – does the code have to be modified? (disabled via the /* and */)

    Thank you,


    Follow up: I tried finding the code and follow the instructions you gave to “mockerbird”, but could not get it to work


    Theme Author Falguni


    You can find all content-*.php files in template-parts folder of Nisarg theme.

    I had found the page you mean.

    on the page “content.php”:

    Line 39 to 42:

    `<?php if ( is_search() || is_home() || is_archive() || is_author()) : // Only display Excerpts for Search ?>
    <div class=”entry-summary”>
    <?php the_excerpt(); ?>
    </div><!– .entry-summary –>`

    When I remove this code in an attempt to have the automatic “Read More” removed, it does not show any Blog Posts anymore, just the Header.


    Hello, I am a begginer and I have similiar problem – when I create a post I would like to choose where the reader can click “read more”, however if I add it in the editor, the text is cut, but the button does not appear on the main page.
    If I don’t add “read more” sign in the editor, the text is cut in the random place (after established amount of words) and the button appears correctly.

    How can I fix it?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Nisarg Blog Posts’ is closed to new replies.