Support » Plugin: NinjaFirewall (WP Edition) - Advanced Security » NinjaFirwall blocks (rule 306) PostFinance payment notifications

  • Resolved mahi38

    (@mahi38)


    Hi,
    When purchasing online at https://www.editions-terre-de-lumiere.com, NinjaFirewall blocks (rule 306) the “PostFinance” payment notification sent back to the customers and ends up in HTTP 403 error

    Url that is blocked :
    https://www.editions-terre-de-lumiere.com/woo_postfinancecw/?cwcontroller=endpoint&c=process&a=index
    Log

    31/Jan/19 15:45:48 #5825431 MEDIUM 306 185.8.54.254 POST /wp_divi/index.php - Bogus user-agent signature - [SERVER:HTTP_USER_AGENT = Mozilla/3.0 (compatible; Indy Library)] - www.editions-terre-de-lumiere.com

    This is not a threat, what can I do about this ?

    thank you !

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author nintechnet

    (@nintechnet)

    Hi,
    You can disable the rule 306 with the “Rules Editor”: select it in the drop-down list and click “Disable it”.

    NinjaFirewall still blocks the payment notification and comes out with rule 531 which I cannot disable in the Rules list because it’s not listed.

    Is there a way to white list IPs to exclude them from being blocked ?

    thank you

    Plugin Author nintechnet

    (@nintechnet)

    Disable the “Firewall Policies > Intermediate Policies > HTTP_USER_AGENT server variable > Block suspicious bots/scanners” policy.

    In the free version, you can whitelist by using the .htninja user configuration file.

    Thank you !

    We bought the Pro+ version to support this plugin which is very good.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.