Support » Plugin: NinjaFirewall (WP Edition) » NinjaFirewall fatal error

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author nintechnet

    (@nintechnet)

    Hi,

    Could you download this file http://nintechnet.com/ninjacheck_php.txt, rename it to ninjacheck.php, upload it to your WordPress folder, call it from your browser and paste the results here ?
    If your domain name is mentioned in the output, you can replace it with ‘xxxxxxx’ instead.

    Thank you for reply as you say i copy the result below:-

    NinjaFirewall (WP edition) troublershooter v1.01

    ========================== %< ============================

    HTTP server: Apache/2.2.22 (Red Hat Enterprise Web Server)
    PHP version: 5.3.3
    PHP SAPI: APACHE2HANDLER
    Loaded INI file: /var/lib/openshift/xxxxxxxxxxxxxxxxxxxx/php/configuration/etc/php.ini
    auto_prepend_file: /var/lib/openshift/xxxxxxxxxxxxxxxxxxxx/app-root/data/plugins/ninjafirewall/lib/firewall.php
    user_ini.filename: .user.ini
    user_ini.cache_ttl: 300
    user INI: not found
    PHPRC: /var/lib/openshift/xxxxxxxxxxxxxxxxxxxx/php//configuration/etc/php.ini
    DOCUMENT_ROOT: /var/lib/openshift/xxxxxxxxxxxxxxxxxxxx/app-root/runtime/repo/php
    wp-config.php: found

    Plugin Author nintechnet

    (@nintechnet)

    Could you please try again, because I can see that 3 lines are missing after wp-config.php: found ?

    thanks for reply,
    i try again as you say but result come same as before

    thanks for reply
    i did as you say but result come same as before
    NinjaFirewall (WP edition) troublershooter v1.01

    ========================== %< ============================

    HTTP server: Apache/2.2.22 (Red Hat Enterprise Web Server)
    PHP version: 5.3.3
    PHP SAPI: APACHE2HANDLER
    Loaded INI file: /var/lib/openshift/xxxxxxxxxxxxxxxxxxxx/php/configuration/etc/php.ini
    auto_prepend_file: /var/lib/openshift/xxxxxxxxxxxxxxxxxxxx/app-root/data/plugins/ninjafirewall/lib/firewall.php
    user_ini.filename: .user.ini
    user_ini.cache_ttl: 300
    user INI: not found
    PHPRC: /var/lib/openshift/xxxxxxxxxxxxxxxxxxxx/php//configuration/etc/php.ini
    DOCUMENT_ROOT: /var/lib/openshift/xxxxxxxxxxxxxxxxxxxx/app-root/runtime/repo/php
    wp-config.php: found

    Plugin Author nintechnet

    (@nintechnet)

    That is very strange, it looks like you have an issue on your side.
    The problem is that the missing lines are very important to solve your problem.
    Can you copy the code below, save it to a PHP script, upload into the directory where is located your wp-config.php file and call it from your browser?

    <?php
    error_reporting(E_ALL);
    ini_set('display_errors', 1);
    echo "<html><body><pre>========================== %< ============================\n";
    include('wp-config.php');
    echo "\nABSPATH:\t\t";
    if (defined('ABSPATH') ) {
    	echo ABSPATH;
    	if ( ABSPATH != getenv('DOCUMENT_ROOT') . '/' ) {
    		echo ' (ABSPATH != DOCUMENT_ROOT)';
    	}
    } else {
    	echo '<font color="red">error: unknown</font>';
    }
    echo "\nWP version:\t\t";
    if (! empty($wp_version) ) {
    	echo $wp_version;
    } else {
    	echo '<font color="red">error: unknown</font>';
    }
    echo "\nWP_CONTENT_DIR:\t\t";
    if (defined('WP_CONTENT_DIR') ) {
    	echo WP_CONTENT_DIR;
    } else {
    	echo '<font color="red">error: unknown</font>';
    }
    echo "\n\n========================== %< ============================\n</pre></body></html>";
    ?>

    hi
    As you say i added php script into my new php file it’s firewall.php and I getting this output below:-
    ========================== %< ============================

    Notice: Use of undefined constant ABSPATH – assumed ‘ABSPATH’ in /var/lib/openshift/529f3e03500446ef230002bf/app-root/runtime/repo/php/wp-config.php on line 39

    Call Stack:
    0.0003 675248 1. {main}() /var/lib/openshift/529f3e03500446ef230002bf/app-root/runtime/repo/php/firewall.php:0
    0.0004 675904 2. include(‘/var/lib/openshift/529f3e03500446ef230002bf/app-root/runtime/repo/php/wp-config.php’) /var/lib/openshift/529f3e03500446ef230002bf/app-root/runtime/repo/php/firewall.php:5

    Warning: require_once(ABSPATH../.openshift/openshift.inc): failed to open stream: No such file or directory in /var/lib/openshift/529f3e03500446ef230002bf/app-root/runtime/repo/php/wp-config.php on line 39

    Call Stack:
    0.0003 675248 1. {main}() /var/lib/openshift/529f3e03500446ef230002bf/app-root/runtime/repo/php/firewall.php:0
    0.0004 675904 2. include(‘/var/lib/openshift/529f3e03500446ef230002bf/app-root/runtime/repo/php/wp-config.php’) /var/lib/openshift/529f3e03500446ef230002bf/app-root/runtime/repo/php/firewall.php:5

    Fatal error: require_once(): Failed opening required ‘ABSPATH../.openshift/openshift.inc’ (include_path=’.:/var/lib/openshift/529f3e03500446ef230002bf/app-root/runtime/repo//libs/:/var/lib/openshift/529f3e03500446ef230002bf/php//phplib/pear/pear/php/:/usr/share/pear/’) in /var/lib/openshift/529f3e03500446ef230002bf/app-root/runtime/repo/php/wp-config.php on line 39

    Call Stack:
    0.0003 675248 1. {main}() /var/lib/openshift/529f3e03500446ef230002bf/app-root/runtime/repo/php/firewall.php:0
    0.0004 675904 2. include(‘/var/lib/openshift/529f3e03500446ef230002bf/app-root/runtime/repo/php/wp-config.php’) /var/lib/openshift/529f3e03500446ef230002bf/app-root/runtime/repo/php/firewall.php:5

    Plugin Author nintechnet

    (@nintechnet)

    Thanks.
    It looks like the problem comes from the OpenShift directory structure (data, repo and runtime).
    NinjaFirewall cannot work with that.
    We will need to make some tests and see if we can fix that problem in the near future.
    Sorry 🙁

    thanks for your support
    its ok no problem i hope you will short that problem in the near future I think you should make free account in openShift and publish your apps there for testing
    BEST OF LUCK 🙂

    Good news :);) problem is shortout now firewall is working properly for this solution first i install zend server and mysql then configure it from openshift cloud server site then i install manually latest version of wordpress 3.8 in openshift
    This problem occur when i use there automation cloud tool service for install wordpress directly from openshift cloud server if i install manually i did not face any problem till now and pluging working well i test it :):)

    Plugin Author nintechnet

    (@nintechnet)

    Excellent 🙂

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘NinjaFirewall fatal error’ is closed to new replies.