Support » Plugin: NinjaFirewall (WP Edition) - Advanced Security Plugin and Firewall » Ninjafirewall activation using WPCLI

  • Resolved eddyferns

    (@eddyferns)


    The Ninjafirewall is successfully installed. But when trying to activate receive the following message:

    “You do not have “unfiltered_html” capability. Please enable it in order to run NinjaFirewall (or make sure you do not have “DISALLOW_UNFILTERED_HTML” in your wp-config.php script).”

    There is no DISALLOW_UNFILTERED_HTML line in wp-config.php.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author nintechnet

    (@nintechnet)

    You need the ‘manage_options’ and ‘unfiltered_html’ capabilities to enable and disable it. With WP CLI, you need to add the admin user with the “–user” parameter:

    $ wp plugin activate ninjafirewall --user=admin_user_here

    Replace “admin_user_here” with the admin login name (or email or id).

    Thread Starter eddyferns

    (@eddyferns)

    Thanks. This works.

    To activate the Ninja Firewall plugin’s Full WAF mode feature the user.ini file needs to be writable. The permissions were 644 for $USER:www-data. I set it to 664 and WAF feature is now activated.

    So is it okay to revert to 644?

    Plugin Author nintechnet

    (@nintechnet)

    I assume it is. On most servers, 0644 is the right value. The only times NinjaFirewall needs to write to that file is when you enable the “Full WAF” mode or uninstall the plugin.

    Thread Starter eddyferns

    (@eddyferns)

    Actually there was a message displayed on the NinjaFirewall’s Dashboard that the file needs to be writable to activate Full WAF.

    Since Full WAF is now activated shall revert to 644.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.