Support » Plugin: Ninja Forms - The Easy and Powerful Forms Builder » Ninja forms stuck on processing will not submit

  • Resolved garikaib

    (@garikaib)


    When I am not logged in (I only login as admin) I am not able to submit forms. The submit button gets stuck on processing. I have tested using different browsers with the same result. I have also tried testing with all the other plugins disabled to no avail.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 24 total)
  • Have you tried it with the Facebook comments plugin disabled.
    You have a Javascript error which is causing admin-ajax.php to throw an error.

    The error appears to be that you haven’t added the domain success.africa to your list of domains for your Facebook App.

    Can’t load URL: The domain of this URL isn’t included in the app’s domains. To be able to load this URL, add all domains and sub-domains of your app to the App Domains field in your app settings.

    But the fact you say you’ve tried it with the other plugins suggests there might be something else. But I can’t see anything until the Facebook error goes away.
    Try disabling the Facebook App plugin and letting us know and I will take another look.

    Regards

    Chris

    One other question, did you enable the Akismet ‘action’ on your form?

    Thank you for the response. I have disabled the Facebook Comments Plugin and purged the Cache.now on https://success.africa/the-ninjas/ . I tried creating my own form but that’s when I noticed the error (not able to submit when logged out) so I just took the vanila contact form that comes with Ninja forms ( I did not change anything) and tried again. I did not see the Akismet action

    Yep – happening here -after the update. Not good

    @garikaib Who are you hosting the site with?
    I’m having the same problem of the admin-ajax.php not loading properly.

    Just found this post might be helpful..
    https://wordpress.stackexchange.com/questions/106252/failed-to-load-wp-admin-admin-ajax-php

    As with that case, I too am hosting with WP Engine. I think I’ll ask them to check out the permissions for the admin-ajax.php file to make sure they didn’t block it.

    Plugin Contributor Zach Skaggs

    (@wpnzach)

    Version 3.2.21 is now on SVN and should fully resolve this issue for anyone impacted.

    @wpnzach
    It looks like 3.2.21 is the version I was running.
    Sorry, but what is SVN?

    I was able to resolve by contacting my hosting company… they worked out some https configuring and allowed that admin-ajax.php file to load. I’m not sure it was anything to do with updating the version of Ninja Forms??

    My form is working now, but I’m confused as to what might have actually fixed it. I supposedly had the latest version (that shouldn’t have had the issue) of the plugin… yet still experienced the issue.

    My hunch is that it was actually the hosting company that fixed my particular version of this problem, and not a simple update of the plugin.

    Plugin Contributor Zach Skaggs

    (@wpnzach)

    3.2.21 launched just a few moments before your last comment, so you may have been auto updated to the new version quickly after my reply by WPEngine

    Sweet! Thanks @wpnzach

    @crbarnett I use a VPS from OVH.
    @wpnzach I can confirm that the problem has been resolved for me.If no one objects I think you can go ahead and mark this as solved and thank you very much for your help and assistance. You are the heroes that make WordPress great.

    having same issue, on one site same configuration same host, the other site is submitting fine, same plugins etc

    I have the same issue, the submit button stuck at “processing”.
    After update the plugin, it will pop up a window, ask for clear old data.
    After few minutes, the form working now. =)

    I am having the same issue. I am still working with tech support but the issue is not resolved yet and I haven’t heard from them since I provided information they requested a day and a half ago, so hoping they haven’t lost track of my issue.

    We have a licensed version. Users make payments using the PayPal add-on but the form gets stuck “processing” when returning from PayPal. Therefore no screen confirmation shows and no notification emails are sent.

    The only time it works is when I am logged in to site and run the form in preview mode. When I run the form in page mode it gets stuck whether I am logged into site admin or not.

    We have tested with 2 different browsers, cleared history, purged cache, followed the protocol disabling all plugins, changing theme to Twenty-X etc. Have run in sandbox and live, and provided error logs.

    Ninja Forms – Addon Manager by The WP Ninjas version 3.0.13,
    Ninja Forms – Conditional Logic by The WP Ninjas version 3.0.22,
    Ninja Forms – Excel Export by Hannes Etzelstorfer version 3.3.1,
    Ninja Forms – Multi-Part Forms by The WP Ninjas version 3.0.24,
    Ninja Forms – PayPal Express by The WP Ninjas version 3.0.14,
    Ninja Forms – Layout & Styles by The WP Ninjas version 3.0.25,
    Ninja Forms – File Uploads by The WP Ninjas version 3.0.20,
    Ninja Forms by The WP Ninjas version 3.3.17

    WP Version: 4.9.8 – Supported
    WP Multisite Enabled: No
    Web Server Info: Apache
    PHP Version: 7.1.1
    MySQL Version: 5.6.41

    It looks like this has been an ongoing problem. Can this be resolved? Would upgrading the php version to 7.2 make a difference?

    Plugin Author Kevin Stover

    (@kstover)

    Hi @jjazzbel,

    This issue is usually caused by your host blocking access to admin-ajax.php unless you are logged-in. If you put the form on a page (not in preview), can you submit the form when logged-in but not when logged-out?

    Can you provide a link to the page where this is happening?

    Hi
    I understand the support team is back on this again and will update if there is a resolution soon.

    It always gets stuck before form actions when submitting from the form page whether logged in to the site’s admin or logged out.
    It is always successful running from form preview.

    Form Link

    Thank you
    Joanne

Viewing 15 replies - 1 through 15 (of 24 total)
  • You must be logged in to reply to this topic.