Support » Plugin: Ninja Forms Contact Form - The Drag and Drop Form Builder for WordPress » Ninja Forms not showing on Chrome or Safari

  • Resolved tch3lp

    (@tch3lp)


    Hi,
    I’m using Ninjaform on a website and it’s not showing the form on Chrome and Safari. Can you please help?!

    Thank you.

Viewing 9 replies - 1 through 9 (of 9 total)
  • I’m also having this problem. Just looked at my forms today and nothing is there. WordPress did recently have an update. And I also updated the Ninja Forms Conditional Logic plugin too. It didn’t get things to work.

    Thread Starter tch3lp

    (@tch3lp)

    @cynthiablue I did some research and understood the problem. So apparently the table was missing out on some CSS. I’ve implemented the following code to “Additional CSS”. Try and see if it works for you too:

    #nf-field-48-container.checkbox-container.label-right .nf-field-label {
    width: 20%;
    }

    #nf-field-48-container.checkbox-container.label-right .nf-field-description {
    margin-right: 0;
    }

    Now I can see the form on both Chrome and Safari.

    • This reply was modified 7 months, 3 weeks ago by tch3lp.

    I had the same problem, but only on one of my sites.

    The reason is that on this one site, I have jquery.js excluded from optimizing in Autoptimize, so it loads first.

    All my other sites are set to include jquery.js in minification, so all scripts load inline in a single file.

    The default setting in Autoptimize is to exclude jquery.js, so this could be an issue for many.

    I had to install https://wordpress.org/plugins/enable-jquery-migrate-helper/

    This fixed the problem. But hopefully, an update to Ninja Forms will rectify this issue soon.

    • This reply was modified 7 months, 3 weeks ago by bobsled.

    Glad someone started this thread.
    Ninja Forms not showing on Firefox and Safari.

    Plugin Contributor Justin McElhaney

    (@jmcelhaney)

    @angelsrock
    Can you make sure that there are no JS errors happening on your page. If there are any, they can cause the Ninja Form not to display.
    In WordPress 5.5 the version of jquery included with WordPress has been updated which is most likely causing the issue you are seeing. https://make.wordpress.org/core/2020/06/29/updating-jquery-version-shipped-with-wordpress/

    Can you try temporarily deactivating all your plugins that are not Ninja Forms add-ons and switching to a default WordPress theme like Twenty Twenty to see if you are still having the same issue?

    Thread Starter tch3lp

    (@tch3lp)

    @jmcelhaney I’m still facing the problem when I access website on other machines. Can you please tell us what can be done?

    If it’s any help, @tch3lp, I have found a few solutions and workarounds.

    1. Install https://wordpress.org/plugins/enable-jquery-migrate-helper/ This fixes the problem. But it’s a temporary measure. It will show you any JS errors. Oddly, it doesn’t show any errors for Ninja Forms, but with the plugin activated it fixes the problem of forms not showing.

    2. In your minify settings, set for minify, but do not aggregate. This fix might slow down your loading speed a little.

    3. If you use Autoptimize, check if js/jquery/jquery.js is excluded. If so, you can try to include it. This worked on one of my sites.

    I had a site that wouldn’t show Ninja forms on IE only. Had https://wordpress.org/plugins/enable-jquery-migrate-helper/ installed.

    Using WP Fastest Cache and turning off minify didn’t help.

    Finally, thanks to post from bobsled, I added js/jquery/jquery.js to “Exclude JS” settings in WP Fastest Cache, and the forms appear.

    Cheers, bobsled!

    Happy it worked @ljezard

    But there is one more workaround I found that works if Autoptimize stops Ninja Forms from showing.

    You can stop Autoptimize from working on the contact page only by adding this line in text view in your page editor.

    <!-- <xsl:stylesheet -->

    It worked for me on the last site I had that was not showing.

    Here is the blog post by Frank Goossens about the hack. https://blog.futtta.be/2018/06/19/quick-trick-to-disable-autoptimize-on-a-page/

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Ninja Forms not showing on Chrome or Safari’ is closed to new replies.