Support » Plugin: reCAPTCHA for Ninja Forms » Ninja forms 3.0.9 and reCaptcha problem

  • I think I set up recaptcha configuration correctly. (Put the Site Key and Secret key from google)
    But the forms only shows “Recaptcha” word.

    Could you give advice for this?

Viewing 15 replies - 1 through 15 (of 20 total)
  • Hi. I am having the same issue. After updating to 3.0.11 I get the word, but no tick box. Formatting on one of my forms is not correct either, with extra space at the top and the X sitting in a weird spot.
    Also, after a rollback I had to disable WP Resume Manager plugin before it would roll forward again.

    Edit: After disabling the WP Resume Manager plugin again the ReCaptcha tick box reappeared on my contact form. However, my site is useless without that plugin!

    • This reply was modified 2 years, 8 months ago by  vonblitz. Reason: Found the issue

    I found a fix to this.

    I rolled back to 2.9 and discovered that somehow the field IDs in my form had changed. I removed recaptcha, corrected the IDs in the form, added recaptcha and now everything works again. Not keen to roll forward to 3 again until after another update.

    Also having issues with RECAPTCHA in Ninja Forms 3.0 on Safari. RECAPTCHA not showing up at all in Safari but works fine in Firefox/Chrome. Is there a fix for this without having to revert back to 2.9?

    I had the same issue. It is VERY easy to solve. Just log out of your admin account and refresh the page with the form on it. Boom!

    I guess because you are logged in as the admin, it doesn’t have to show you the reCAPTCHA. I have been troubleshooting this for hours. I decided to look at the website on a different computer (this computer was not logged in at all) and I was able to see the reCAPTCHA. Then I decided to log out on my main computer and refreshed the page and I was able to see it.

    I hope this helps some of you out there!

    @schultz1981

    Thanks a lot. I’ll give this a look.

    Your welcome vonblitz! Let us know if it worked for you!

    At this point the upgrade to 3 is not working at all from the rolled back version. So I can’t test it.

    Didn’t seem to work.

    not working for me either…

    I’m sorry it is not working for you guys. Have you tried looking at your form on another device/computer? Or clearing your cache?

    Has anybody solved this problem? I’m using ninja form v3 and reCaptcha and can’t get anything to show up in the reCaptcha box…

    I am having the same issue.
    The original post was posted 5 months ago… How’s that not solved until now?

    Hello everybody,

    I found the issue and it is quite easy to solve.
    It appears that Ninja Forms does not add the required JavaScript of reCAPTCHA to the website’s HTML header.

    Using a plugin like this:
    https://wordpress.org/plugins/head-footer-code/

    Add the following code before </HEAD>:
    <script src=’https://www.google.com/recaptcha/api.js’></script>

    Then the reCAPTCHA will show up.

    I hope that helps.

    I experience issues with reCAPTCHA on Chrome and Opera, which use the same engine. The reCAPCHA sometimes appears on the first load as it should, sometimes it needs a page refresh in order to load, and sometimes it will never load.
    It works perfectly fine on Firefox, though.
    I am sure it is not a cache problem, so I assume that a Chrome update will fix this in the near future.

    • This reply was modified 2 years, 4 months ago by  dchara01.

    After some troubleshooting I finally found out that adding the script in the footer instead of the header, resolves the issue and the reCAPTCHA starts showing in all browsers.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Ninja forms 3.0.9 and reCaptcha problem’ is closed to new replies.