Support » Plugin: Nimble Page Builder » Nimble Builder and Yoast SEO Not Integrating?

  • Hi,

    I have built my site using Nimble Builder and the Customizr theme. As I am trying to optimize my site for SEO using Yoast SEO, I am concerned that Yoast is not integrating with Nimble Builder. I am brand new to SEO requirements and Yoast has some great features that I am trying to use. But it seems that Yoast does not recognize that I have content built with Nimble Builder. It seems to just be analyzing the blank WordPress pages upon which Nimble Builder sits and assuming I have no content.

    On almost all my pages, Yoast thinks I have a text length of 0 words. This includes https://test.restartcda.com/, https://test.restartcda.com/specialties/, and https://test.restartcda.com/depression/ as a few examples. The one exception is this page: https://test.restartcda.com/angela-holland/ Yoast recognizes an accurate word count of 151 words on this page. I don’t know why this is the case, as all these pages are built with Nimble Builder.

    Yoast analysis also incorrectly says that I don’t have internal links on these pages which I do.

    I have read what you have said about other people’s similar concerns with SEO integration with Nimble builder here: https://wordpress.org/support/topic/nimble-editor-with-yoast-seo/ and more recently here: https://wordpress.org/support/topic/low-ranking-on-google-since-nimble/

    I am concerned that these issues are not resolved. Hopefully, I am doing something wrong. I need to launch my website soon and don’t have time to start over from scratch, but I really want to be able to make Nimble Builder work with Yoast if at all possible.

    Thank you in advance for your help,

    Rob

    ### Begin System Info (Generated 2021-07-20 16:46:03) ###
    ------------ SITE INFO
    Site URL:                 https://test.restartcda.com
    Home URL:                 https://test.restartcda.com
    Multisite:                No
    
    ------------ USER BROWSER
    Platform:                 Windows 
    Browser Name:             Firefox  
    Browser Version:          88.0 
    
    ------------ WORDPRESS CONFIG
    WP Version:               5.7.2
    Language:                 en_US
    Permalink Structure:      /%postname%/
    Active Theme:             customizr-child 1.0
    Parent Theme:             Customizr 4.4.7
    Show On Front:            page
    Page On Front:            Home (#7)
    Page For Posts:           Unset
    ABSPATH:                  /home/damasc10/public_html/test/
    WP_DEBUG:                 Disabled
    WP Memory Limit:          40MB
    
    ------------ NIMBLE CONFIGURATION
    Version:                  3.1.18
    Upgraded From:            3.1.17
    Started With:             1.10.5
    
    ------------ MU PLUGINS
    Health Check Troubleshooting Mode: 1.7.2
    
    ------------ WP ACTIVE PLUGINS
    All In One WP Security: 4.4.9
    Antispam Bee: 2.9.4
    Childify Me: 1.2.3
    Duplicate Menu: 0.2.2
    Health Check & Troubleshooting: 1.4.5
    Jetpack: 9.9
    Limit Login Attempts Reloaded: 2.23.0
    Nimble Page Builder: 3.1.18
    OMGF: 4.4.4
    PHP Compatibility Checker: 1.5.0
    Quiz And Survey Master: 7.2.3
    Really Simple SSL: 5.0.3
    Stackable - Gutenberg Blocks: 2.17.2
    Stop Spammers: 2021.17
    Videopack (formerly Video Embed & Thumbnail Generator): 4.7.1
    Video Thumbnails: 2.12.3
    WP Rollback: 1.7.1
    Yoast Duplicate Post: 4.1.2
    Yoast SEO: 16.7
    
    ------------ WP INACTIVE PLUGINS
    Photo Gallery: 1.5.79
    Rank Math SEO: 1.0.68
    reCaptcha by BestWebSoft: 1.62
    Swap Google Fonts Display: 1.0.6
    W3 Total Cache: 2.1.3 (needs update - 2.1.5)
    WP Super Cache: 1.7.3 (needs update - 1.7.4)
    
    ------------ WEBSERVER CONFIG
    PHP Version:              7.4.19
    MySQL Version:            5.5.5
    Webserver Info:           Apache
    Write/Read permissions:   OK
    
    ------------ PHP CONFIG
    Memory Limit:             768M
    Upload Max Size:          512M
    Post Max Size:            512M
    Upload Max Filesize:      512M
    Time Limit:               30
    Max Input Vars:           6200
    Display Errors:           N/A
    PHP Arg Separator:        &
    PHP Allow URL File Open:  1
    
    ### End System Info ###
    • This topic was modified 2 months, 1 week ago by rob2550.
    • This topic was modified 2 months, 1 week ago by rob2550.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Nicolas

    (@nikeo)

    Hello,
    Thanks for reporting this issue when using Yoast SEO plugin. Nimble Builder is supposed to integrate with Yoast content analysis tool, this includes internal links added in Nimble Builder content.
    I’m exploring why this happens for you on a similar website using Customizr + Nimble Builder, and I’ll keep you posted.

    Plugin Author Nicolas

    (@nikeo)

    I did some tests on a page of the demo site : https://demo.presscustomizr.com/yoast-integration-example/
    I could reproduce the problem at first. Then I disabled the classic editor plugin and Yoast content analysis tool worked fine : I could see the number of words, the internal links, etc.
    I did not isolate yet why the problem happens when the classic editor plugin is activated.
    In your case, I don’t see the classic editor plugin in the list of active plugins, so I’m not sure what happens on your website. It may be a conflict with another plugin.

    You’ll find a screenshot of my test on the github issue : https://github.com/presscustomizr/nimble-builder/issues/865

    Thread Starter rob2550

    (@rob2550)

    Hi,

    Thanks for getting back to me. No, I do not have the classic editor plugin installed.

    I manually disabled all plugins except for Nimble Builder and Yoast SEO while still using Customizr theme. At first, Yoast said that the one page that was previously showing an accurate word count ( https://test.restartcda.com/angela-holland/) now had zero words. Another page (https://test.restartcda.com/specialties) that previously said zero words displayed a proper word count and recognized internal links. It also recognized text on 7 other Nimble Builder pages, but not within the other half of my site.

    But then something weird happened. As I was still writing this message and double checking these pages, Yoast displayed a word count of zero again for all of them! It happened within 10 or 20 minutes of having opened them all in multiple tabs. I did not install anything or do anything else during that time.

    After that, I noticed WordPress and Customizr had newer versions so I updated them. I then used the “Health Check and Troubleshooting” plugin to temporarily disable all plugins, and activated only Nimble Builder and Yoast SEO. Yoast continued to report all pages as having zero words, except for Specialities (https://test.restartcda.com/specialties). But then I looked a minute later and Specialities was listing a zero word count again. I refreshed the page a few minutes later and it was displaying a word count again. I refreshed it again a few minutes later and it was back to zero again.

    It seems as though Yoast cannot consistently read Nimble Builder pages. It accurately reads some pages but then a few minutes later, it inexplicably stops reading them again.

    If you have any other troubleshooting suggestions or need more info, let me know. I’m hoping to get this figured out. My current system info is listed again below.

    Thanks,
    Rob

    ### Begin System Info (Generated 2021-07-21 23:59:29) ###
    ------------ SITE INFO
    Site URL:                 https://test.restartcda.com
    Home URL:                 https://test.restartcda.com
    Multisite:                No
    
    ------------ USER BROWSER
    Platform:                 Windows 
    Browser Name:             Firefox  
    Browser Version:          88.0 
    
    ------------ WORDPRESS CONFIG
    WP Version:               5.8
    Language:                 en_US
    Permalink Structure:      /%postname%/
    Active Theme:             Twenty Twenty 1.7
    Show On Front:            page
    Page On Front:            Home (#7)
    Page For Posts:           Unset
    ABSPATH:                  /home/damasc10/public_html/test/
    WP_DEBUG:                 Disabled
    WP Memory Limit:          40MB
    
    ------------ NIMBLE CONFIGURATION
    Version:                  3.1.19
    Upgraded From:            3.1.18
    Started With:             1.10.5
    
    ------------ MU PLUGINS
    Health Check Troubleshooting Mode: 1.7.2
    
    ------------ WP ACTIVE PLUGINS
    Health Check & Troubleshooting: 1.4.5
    Nimble Page Builder: 3.1.19
    Yoast SEO: 16.7
    
    ------------ WP INACTIVE PLUGINS
    All In One WP Security: 4.4.9
    Antispam Bee: 2.9.4
    Childify Me: 1.2.3
    Duplicate Menu: 0.2.2
    Jetpack: 9.9.1
    Limit Login Attempts Reloaded: 2.23.0
    OMGF: 4.4.4
    Photo Gallery: 1.5.80
    PHP Compatibility Checker: 1.5.0
    Quiz And Survey Master: 7.2.3
    Rank Math SEO: 1.0.68
    Really Simple SSL: 5.0.3
    reCaptcha by BestWebSoft: 1.62
    Stackable - Gutenberg Blocks: 2.17.3
    Stop Spammers: 2021.17
    Swap Google Fonts Display: 1.0.6
    Videopack (formerly Video Embed & Thumbnail Generator): 4.7.1
    Video Thumbnails: 2.12.3
    W3 Total Cache: 2.1.3 (needs update - 2.1.5)
    WP Rollback: 1.7.1
    WP Super Cache: 1.7.3 (needs update - 1.7.4)
    Yoast Duplicate Post: 4.1.2
    
    ------------ WEBSERVER CONFIG
    PHP Version:              7.4.19
    MySQL Version:            5.5.5
    Webserver Info:           Apache
    Write/Read permissions:   OK
    
    ------------ PHP CONFIG
    Memory Limit:             768M
    Upload Max Size:          512M
    Post Max Size:            512M
    Upload Max Filesize:      512M
    Time Limit:               30
    Max Input Vars:           6200
    Display Errors:           N/A
    PHP Arg Separator:        &
    PHP Allow URL File Open:  1
    
    ### End System Info ###
    Thread Starter rob2550

    (@rob2550)

    I just disabled the Yoast SEO plugin and tried Rank Math SEO instead, and Rank Math recognized the Nimble Builder content on all my pages. So the issue seems to lie specifically with Yoast SEO.

    I’d prefer to use Yoast as I’ve already started adding content with it and don’t want to have to start over. But I may have to use Rank Math until the issue with Yoast can be fixed.

    Plugin Author Nicolas

    (@nikeo)

    OK good to know.
    I’m still exploring why this problem occurs with Yoast SEO. Nimble Builder uses the official Yoast javascript API so this should work.
    Thanks for providing all those details about your issue.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.