Support » Plugin: Yoast SEO » Nightmare with my images

  • Hi,
    In recent days, (Yoast version 7.0 -or 7.1-), the search console google panics. 404 errors are raining continuously. My images are no longer redirected correctly. Since a week, the number of visitors is decreasing. My site is based on photographs, and so they are well indexed, and especially redirected to the parent post. I realized that you deleted this option (redirected the media to the parent post). Maybe it’s also about deleting media in the XML sitemap? in brief, it’s absolutely not SEO friendly in my case. Do you think correct these options ? Or give the choice with these options?
    Thank you

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    From Yoast SEO v7.0, the redirect media (attachment) pages to parent attached pages is removed. Therefore, if you don’t wish the media (attachment) pages to be redirected to the media files itself, you can disable this directly from the Yoast SEO -> Search Appearance -> Media (tab).

    ok, if I disable this option, the media will be redirected to the post parent?
    If not, how can I redirect the media to the parent post ?

    We are seeing something similar. Since early March (Yoast 7x? release) the media URL redirect that was in place was removed, so in our case, thousands of image URLs were submitted to the ‘attachment’ sitemap. We noticed this a few days later and turned on the apparently new button in Yoast 7, that you are referencing. But this should have been done automatically from v6 to v7. By the time we noticed, Google bots already started indexing these thousands of URLs, and turning on the redirect has only partially fixed the issue. In the Google new console, there is a section for ‘crawl anomalies’, and it seems that all the redirected image URLs to the media URL are now stacking up in Google’s crawl anomalies report. We are also seeing some decline in organic traffic that coincides with this pattern.

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    @wb1968 Disabling the media (attachment) redirects won’t redirect to the media (attachment) parent pages anymore as this feature has been completely removed from Yoast SEO. Disabling the media (attachment) redirects will show the attachment page.

    Hi,
    we are not alone:
    bug-attachments-not-redirecting-to-parent-pages
    (an Github topic is open for that)

    similar problem:
    redirect-attachment-urls-not-working-2

    or:
    redirect-image-attachment-urls-feature-missing

    If I summarize your answers:
    – I need to install a plugin to redirect the media to the parent post
    – I need to install a plugin to put the media in the sitemap (the media is very important to me)

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    Previously, we had an option to redirect attachment URLs to their post parent. This didn’t work for attachments that weren’t attached to anything. This new setting redirects all attachment URLs to the URL of the original image or media item. This means if you’d like to redirect the media (attachment) pages to the attached pages, you’ll need to use a 3rd party plugin.

    Same here.

    And this change in functionality has created over 7K crawl anomalies on Search Console. Yoast tells me it’s a Google Search Console problem. I disagree. This issue did not exist before their change.

    Maybe it’s time to go to another SEO plugin?

    I am having the same issues.
    I have tried blocking the url in the robots.txt (and testing in accurately in google search console)
    removing the url in temporary url in google search console – nothin works and the images are all that show up in google search results.

    can anyone solve this?

    • This reply was modified 1 year, 10 months ago by GeraldineWard.
    • This reply was modified 1 year, 10 months ago by GeraldineWard. Reason: made an error - google search console (I wrote results instead of console)

    This has created an absolute disaster on my image-based site. And with no warning. And the advice to get a 3rd party plug-in to fix the disaster Yoast created. It took me forever to figure out what was going on, since I hadn’t changed anything on my site. Starting to wonder why I am paying for Yoast.

    And I still don’t understand what I should have Yoast set at, since the description telling you what to do and and the text on the buttons don’t match.

    Media & attachment URLs Learn more about the Media and attachment URLs setting
    When you upload media (an image or video for example) to WordPress, it doesn’t just save the media, it creates an attachment URL for it. These attachment pages are quite empty: they contain the media item and maybe a title if you entered one. Because of that, if you never use these attachment URLs, it’s better to disable them, and redirect them to the media item itself.

    We recommend you set this to Yes.

    Redirect attachment URLs to the attachment itself?
    Yes or no

    The info recommends setting this to “no” and the text above the buttons recommends setting it to “yes”!????

    Is setting it to yes (as recommended on the buttons, but not in the info section) what is creating all these image files??

    How do I get all those image “posts” out of Google????

    @travelgal Were you able to get this fixed? I’ve been having these problems with my site and I’m pissed.

    Ditto. Maybe the best thing would be to deactivate Yoast?

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Nightmare with my images’ is closed to new replies.