Support » How-To and Troubleshooting » nightly 2004-02-13: safe mode troubles

nightly 2004-02-13: safe mode troubles

  • hi,
    just updated my 1.0 to nightly. (just wrote the new files over the old ones and run upgrade.php, right?). everythings works fine (as before), only the options tab fails with the following error:
    Warning: SAFE MODE Restriction in effect. The script whose uid is 0 is not allowed to access ./optionhandler.php owned by uid 32004 in /home/www/web1/html/wordpress/wp-admin/options-general.php on line 37
    Fatal error: Failed opening required ‘optionhandler.php’ (include_path=’.:/usr/share/pear’) in /home/www/web1/html/wordpress/wp-admin/options-general.php on line 37
    i didn’t change anything wrt safe mode and it worked before… what am i missing?
    thanks – sdf

Viewing 6 replies - 1 through 6 (of 6 total)
  • Which nightly? I just installed a 2004-02-13 and Options isn’t giving me any safe mode hassles.
    Is it definately safe mode, and not PHP misrepresenting a permissions problem as safe mode?

    D’oh. Might be I could read the subject, and see which nightly. And once you get past that, you’ll run into options troubles when you try to set anything, since options.php is trying to set a redirect header when admin-header.php has already started output. Oops.

    so i should wait a few days and try again?

    Oh, probably. I can’t quite see where he’s headed with it, so I can’t tell you how to get there first 😉
    You can make it possible to set options without the “already started” error by just throwing an ob_start(); at the very start of admin-header.php, though that doesn’t give you the “3 setting(s) saved …” message.


Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘nightly 2004-02-13: safe mode troubles’ is closed to new replies.
Skip to toolbar