Support » Plugin: Shortcode Menu » Nie but causes W3c validation errors

  • The plugin works very well but it causes W3C validation errors because css style and javascript are in the middle of the page.
    Is it possible to put the style and the scripts in the right place?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Amit Sukapure

    (@amitsukapure)

    Hi,

    To consider loading time I’ve load scripts and styles if and only if page contains respective shortcode.

    WordPress process execution as follows,
    wp_head
    the_content (your shortcode)
    wp_footer
    So while processing body part wp_head part is already processed and thus WP is adding these to footer of page.

    Number of plugin used this technique to stop loading scripts and styles unnecessarily.

    Hope that clarify to you.

    And thanks for you comment.

    Hi,

    Thank you for taking time to answer.
    Anyway it’s a nice plugin (I forgot the “c” in the previous message :-)).

    Best regards

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Nie but causes W3c validation errors’ is closed to new replies.