Support » Themes and Templates » Weavr » [Resolved] Nice update! Now how do I get my "Home" page from another theme to reappear?

[Resolved] Nice update! Now how do I get my "Home" page from another theme to reappear?

  • Great update, I use the theme for a local community studio, but couldn’t use it because it would scrunch up or stretch the header picture depending on the size of the browser window. Now I can use it, and I like it.

    Question: I had a “Home” page in the menu where my blog entries appeared, and it’s my landing page, using the WP Twenty-Eleven theme. Now it’s gone from the menu – how can I get it back on the menu?


    http://www.michaelpalermo.com if that helps.

Viewing 11 replies - 1 through 11 (of 11 total)
  • I am a complete Rookie. I am setting up my first web page and need suggestions. All of the themes look great but, which Themes works best for a retail Business with a check out and payment feature.

    Any ideas are appreciated


    @mpalermo – go to Appearance -> Customise. On the left where it says to choose your home page, click on that and select ‘Static Page’ – an option box will appear and you can then choose your Home page from the selection.

    To include your home page as a menu item, go to Appearance -> Menus and from the panel on the left of that page, choose your home page and click ‘Add To Menu’.

    @masusan – you will need to have a look at the many e-commerce plugins available for WordPress. I can recommend WooCommerce for it’s extensive flexibility, but without knowing your business or retail structure, it will be hard to give you any further guidance.


    Theme Author welshhuw


    Hi mpalermo,

    I am glad you like the update. Stay tuned; more updates coming real soon.

    I am not 100% sure I follow your query but have some suggestions:
    1) Have you set Settings > Reading > Front Page = ‘Home’?
    2) Have you added ‘Home’ to the Custom Menu?

    I hope that solves your problem. If not, reply back here and I can take a closer look for you.


    Theme Author welshhuw


    Thank you for your in depth reply @tareq. We both wrote the same answers at the same time!


    No problem Huw!

    Thanks for the thanks!

    Oh I do like helping people.

    Theme Author welshhuw


    @masusan This theme supports WooCommerce if you wanted to use it.


    Hi. Not working. I’ve included a link to some screenshots, and as you can see I changed the theme back to Twenty-Eleven. On the far left of the menu there is a “Home” button, in 2011 theme.

    Then, I changed it to Weavr (screenshot) and there is no “Home” button.

    Then, when I try to follow your instructions, you can see from the screen shot “Home” does not appear as a “Page” option anywhere, see the screenshots of that.

    I suspect TwentyEleven created the “home” page/link but it isn’t a “Page” per se in the menus? Something native to 2011 that’s not being carried over? I note that “Home” does not appear as a Page option in 2011 either. Hmmmm

    Link to photos: http://www.michaelpalermo.com/temp/


    Theme Author welshhuw


    I’m guessing twenty eleven had a custom link with the label home.
    Please add one you the main menu and then save the menu

    Theme Author welshhuw


    @mpalermo You will most likely need to ‘set/save’ your custom menu such as you had in the 2011 theme. Because you changed themes and the menu theme locations can be different you need to re-save them.

    Log in, visit Appearence > Menus, at the bottom of your main menu, make sure the Theme Locations : Primary Menu box is checked.

    None of that worked, here’s what worked, using a combination of the suggestions:

    I think 2011 was taking my “Pages” and making them into menu items – I never used the Appearance > Menus option with that theme (I initially at some point did, there were menu items that I wasn’t using from an earlier excursion), because under “Page Attributes” on each Page editor, I would enter a number for what order I wanted it to appear in the menu and that worked. Not relevant but background.

    Here goes:

    1. I activated the 2011 theme.

    2. I went to Appearance > Menus and deleted the menu that was there, so there was no menu. After “saving” the deletion, the page was blank for a few moments, then all my Pages automatically re-appeared along with a “Home” page shown as “Custom”. The link to this custom-Home page was to my main web site, that’s what I wanted. “Save” this.

    3. I activated Weavr and went to my site to see what happened. Now, the “Home” page link does not appear on the site itself.

    4. I went to Appearance > Menus (still in Weavr, now) and the Menu items from 2011 were there – including the “Home” – Custom page that I needed.

    5. I ticked “Primary Menu” to active, saved the whole thing, and now it works.

    6. I now have to re-do each page, because they all defaulted to the template with the (Right) sidebar and some of the widgets are missing, but that’s easy.

    It’s working.

    Thanks all for the brainstorming. You think these computer things would get easier, eh?


    I’m guessing twenty eleven had a custom link with the label home.
    Please add one you the main menu and then save the menu

    I think I did that, just in a round-about way? I couldn’t find how to add just a custom page like that.


Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] Nice update! Now how do I get my "Home" page from another theme to reappear?’ is closed to new replies.
Skip to toolbar