Support » Everything else WordPress » nice pemalinks leads to 404 error

  • Resolved naddie

    (@naddie)


    After moving my blog into a new server, my nice permalinks (/%year%/%monthnum%/%day%/%postname%/) seems to give me a 404 error (http://she-falls-apart.org/2007/05/26/fragile-heart/). However, if I switch to default (?p=123) it seems fine. I’m not too sure what is causing this. Could someone kindly help me? Thank you!

Viewing 7 replies - 1 through 7 (of 7 total)
  • whooami

    (@whooami)

    Member

    did you update your permalinks?

    was wordpress able to write to your .htaccess when/if you did so?

    naddie

    (@naddie)

    I updated the permalinks. However, when I checked my .htaccess files, it does not seem updated. I did chmod my .htaccess file to 666. I’m not sure what codes I should manually input into my .htaccess files to update my permalink struture.

    whooami

    (@whooami)

    Member

    if you chmood your .htaccess to 666, and update your permalinks, wp will do the work.

    then you just make sure to chmod it back to 644 or whatever.

    naddie

    (@naddie)

    That was what I had attempted before making this post. It seems like my .htaccess file was not updated by WP at all. WP used to provide a certain code for manually upating .htaccess should the file is not chmod to 666. But they don’t seem to provide that now. May I know what is that code so perhaps I could attempt that and see if my permalinks do work then?

    Thank you!

    whooami

    (@whooami)

    Member

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress
    naddie

    (@naddie)

    Thank you!

    whooami

    (@whooami)

    Member

    youre welcome 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘nice pemalinks leads to 404 error’ is closed to new replies.