Support » Plugin: Country Caching Extension » Nice concept, but got "white screen".

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author wrigs1

    (@wrigs1)

    Hi fidha.

    I’ve managed to replicate (and fix in test) the white screen. I replicated the problem when the “GeoIP Detection” plugin was installed on my test site. Each plugin is separately including a copy of the 3rd party Maxmind script and this duplication can cause problems.

    Before I release the fix: could you let me know what GeoIP plugins you are using – and if feasible I’ll also test it against some of them.

    White screen on non admin pages can be “quick fixed” by going to Country Caching settings, unchecking “Enable ZC/QC” and saving. Then clearing QC cache.

    https://wordpress.org/plugins/country-caching-extension/faq/ explains how to remove the plugin if that doesn’t work – but omits to mention you should afterwards go to QuickCache settings and clear cache.

    I Use a plugin that also use a Maxmind’s GeoIP.dat, it’s called Country Filter (http://www.codediesel.com/plugins/country-filter/). Use it to serve ads based on geolocation.

    Formerly it’s available on wordpress.org, but now it removed and turn into paid plugin.

    Regards,
    Frid

    Plugin Author wrigs1

    (@wrigs1)

    Hi Frid,

    I’ll release a new version tomorrow in tandem with a new version of the “Category Country Aware” plugin.

    I’ve not checked it against the plugin you are using (I’m not paying for it!) – but hopefully the changes will fix your issue.

    If you can’t wait for the “official” version, know what you are doing, and are not using the CCA plugin as well: you can download an advance copy from the WP repository https://downloads.wordpress.org/plugin/country-caching-extension.0.6.0.zip.

    Hi,
    It’s great to know that you’ve take care on this issue.
    I’m also contacting you via your site’s (wptest.means.us.com) contact form.

    Regards,
    Frid

    Plugin Author wrigs1

    (@wrigs1)

    I’m waiting to hear back from Frid but I’ve uploaded version 0.6.0 which should fix the problem.

    If you have a test site that uses some geoip plugins, and you have wp-debug switched on you may find you get some PHP notices (the plugin still works). My bad I meant to upload version 0.6.1 but as I’ve only just published 0.6.0 I’ll leave it a few weeks. If you also have the latest version of the CCA plugin installed it will fix this PHP notice issue.

    Plugin Author wrigs1

    (@wrigs1)

    I replicated the problem , and it was fixed by version 0.6.0 (released last week). Its been over a week and I’ve not heard back from Frid so I’m marking this topic as resolved.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Nice concept, but got "white screen".’ is closed to new replies.