Support » Plugin: SAML 2.0 Single Sign-On » Nginx configuration (with Multisite)?

  • Resolved Ben Overmyer

    (@manatrance)


    Trying to get this working with Multisite on Nginx. When I access module.php directly, it’s complaining about PATH_INFO missing. When I access the theoretical endpoint of the metadata (wp-content/plugins/saml-20-single-sign-on/saml/www/module.php/saml/sp/metadata.php/1), I get a WordPress “Not Found” error page.

    Little help?

    https://wordpress.org/plugins/saml-20-single-sign-on/

Viewing 1 replies (of 1 total)
  • Ben Overmyer

    (@manatrance)

    Figured it out. Below is my virtualhost config that fixed the problem.

    server {
            listen 80 default;
            server_name *.example.com example.com;
    
            root /srv/web/wpmulti;
    
            access_log      /var/log/nginx/example.access.log;
            error_log       /var/log/nginx/example.error.log;
    
            index index.html;
    
            location / {
                index index.html index.htm index.php;
                include global/restrictions.conf;
                include global/wordpress-ms-subdir.conf;
                rewrite ^ http://example.com$request_uri permanent;
            }
    
            location ^~ /wp-content/plugins/saml-20-single-sign-on {
                location ~ ^(?<script_name>.*?\.php)(?<path_info>/.*)?$ {
                    include fastcgi_params;
                    fastcgi_param SCRIPT_FILENAME $document_root$script_name;
                    fastcgi_param PATH_INFO $path_info;
                    fastcgi_param PATH_TRANSLATED $document_root$path_info;
                    fastcgi_pass unix:/var/run/php5-fpm.sock;
                }
            }
        }
Viewing 1 replies (of 1 total)
  • The topic ‘Nginx configuration (with Multisite)?’ is closed to new replies.