Support » Plugin: Yoast SEO » ngg_tag pages indexation

  • Resolved gintsg

    (@gintsg)


    Hi,

    I noticed that something is not working right with NGG_TAG pages.

    1. The problem is that NGG_tag pages are still indexable after changing the settings under “Search Appearance – Yoast SEO” -> “Picture tag (ngg_tag)” -> “Show Picture tag in search results?” setting to No. But changing these setting, the tag pages were at least removed from the sitemap.xml file.

    2. If I am visiting and editing https://domain.co.nz/ngg_tag/some-tag-name/nggallery/ page. In this page, I can’t see a setting under Yoast SEO to set up this page as NOINDEX. There are only settings for: “Allow search engines to show this Picture tag in search results?” but this doesn’t change anything.

    Using:
    WordPress 4.9.4
    Yost SEO 7.0.3
    NextGEN Gallery 2.2.54
    NextGEN Plus 1.5.7

Viewing 12 replies - 1 through 12 (of 12 total)
  • Update:
    The same issue with latest Yost SEO 7.1.0 version. All the same issues with 3 different websites. Please find the way to add Robots NOINDEX tag on these NGG_Tag pages.

    Thanks!

    Plugin Support Michael Tina

    (@mikes41720)

    Hello,

    If you set the option of Allow search engines to show this Tag in search results to NO, it is expected to add a noindex tag and be excluded from the XML Sitemap. The URL you provided is throwing a 404. We’re not familiar with the NGG plugin, but if you are still not getting a “noindex” tag for that post or page, then you may want to perform a conflict check.

    Can you try and gather as much information for us as possible? Please perform the following:

    1. Make sure the issue doesn’t persist when Yoast SEO is disabled.
    2. Check for conflicts.
    3. Check for JavaScript errors with your console.

    If you find any JavaScript errors related to Yoast SEO or if there is a conflict with a plugin or a theme, you can create a new GitHub issue for our developers. Please report the issue to a third party developer as well.

    If you didn’t find any conflicts or errors, we think the issue is specific to your site. We’d need to investigate further but are unable to do so on these forums. You can purchase Yoast SEO Premium and receive our Premium email support and we can help you further.

    Thank you for your response!

    The only thing that I checked, there is no JS errors. I can’t do full check at this stage. I have access only to the live version and there are quite a big peaks in traffic.

    I posted the issue in NextGen Gallery support threads as well.

    Thanks,
    Gints.

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    We understand you don’t wish to perform the full conflict check on your production site. Therefore, we recommend you to create a staging site to perform the conflict check.

    On the other hand, please let us know once the NextGen Gallery support says.

    So, I just installed completely new WordPress and installed only two plugins Yoast SEO and NextGEN Gallery. Everything is the latest version.

    Answers:
    1. Make sure the issue doesn’t persist when Yoast SEO is disabled.
    If the Yoast SEO is disabled there don’t have any robots tags as well. But it’s because Yoast SEO is disabled which should do the task.

    2. Check for conflicts.
    I installed the Health Check. The check doesn’t make sense because I have installed only two additional plugins and WordPress default theme. The only two plugins what I can disable for Health Check are Yoast SEO and NextGEN Gallery.

    3. Check for JavaScript errors with your console.
    There don’t have any JS errors.

    At the moment NextGENN Support team didn’t answer my message on their support board. No answer yet.

    Here is my test page: http://wptest.musicpm.lv/ngg_tag/test-tag/
    Using:
    WordPress 4.9.4
    Twenty Seventeen 1.4
    Yoast SEO 7.1.0
    NextGEN Gallery 2.2.54

    Configuration:
    Added test gallery in NextGEN Gallery with one tag: test-tag.
    The only settings what I changed in Yoast SEO are: “Picture tag (ngg_tag)” -> “Show Picture tag in search results?” set to NO

    For security, I added X-Robots tag from server side sitewide. But this shouldn’t impact the issues.

    Should I upload this on GitHub or this description will get sent to developers?

    Thanks!

    Plugin Support MariusG

    (@marius_codeinwp)

    In order for us to replicate this issue, please make sure you still have the Health Check plugin, then go to Dashboard → Health Check → Debug information and copy-paste the information here.

    This will allow us to replicate your environment, and hopefully the issue too.

    • This reply was modified 1 year, 3 months ago by  MariusG.

    Thank you! Here it is:
    `
    ### WordPress ###

    Version: 4.9.4
    Language: en_NZ
    Permalink structure: /%year%/%monthnum%/%day%/%postname%/
    Is this site using HTTPS?: No
    Can anyone register on this site?: No
    Default comment status: open
    Is this a multisite?: No
    User Count: 1
    Communication with WordPress.org: WordPress.org is reachable
    Create loopback requests: The loopback request to your site completed successfully.

    ### Active theme ###

    Name: Twenty Seventeen
    Version: 1.4
    Author: the WordPress team
    Author website: https://wordpress.org/
    Parent theme: Not a child theme
    Supported theme features: automatic-feed-links, title-tag, post-thumbnails, menus, html5, post-formats, custom-logo, customize-selective-refresh-widgets, editor-style, starter-content, custom-header, widgets

    ### Other themes (2) ###

    Twenty Fifteen (twentyfifteen): Version 1.9 by the WordPress team
    Twenty Sixteen (twentysixteen): Version 1.4 by the WordPress team

    ### Must Use Plugins (1) ###

    Health Check Disable Plugins: Version 1.3

    ### Active Plugins (3) ###

    Health Check: Version 1.0.1 by The WordPress.org community
    NextGEN Gallery: Version 2.2.54 by Imagely
    Yoast SEO: Version 7.1 by Team Yoast

    ### Inactive Plugins (2) ###

    Akismet Anti-Spam: Version 4.0.3 by Automattic
    Hello Dolly: Version 1.6 by Matt Mullenweg

    ### Media handling ###

    Active editor: WP_Image_Editor_Imagick
    Imagick Module Version: 1673
    ImageMagick Version: ImageMagick 6.8.9-9 Q16 x86_64 2017-07-31 http://www.imagemagick.org
    Imagick Resource Limits:
    area: 8 GB
    disk: -1
    file: 768
    map: 8 GB
    memory: 4 GB
    thread: 1
    GD Version: 2.1.1
    Ghostscript Version: Unable to determine if Ghostscript is installed

    ### Server ###

    Server architecture: Linux 4.4.0-116-generic x86_64
    PHP Version: 7.0.28-0ubuntu0.16.04.1 (Supports 64bit values)
    PHP SAPI: fpm-fcgi
    PHP max input variables: 1000
    PHP time limit: 30
    PHP memory limit: 256M
    Max input time: 60
    Upload max filesize: 128M
    PHP post max size: 128M
    cURL Version: 7.47.0 OpenSSL/1.0.2g
    SUHOSIN installed: No
    Is the Imagick library available: Yes

    ### Database ###

    Extension: mysqli
    Server version: 5.7.21-0ubuntu0.16.04.1
    Client version: mysqlnd 5.0.12-dev – 20150407 – $Id: b5c5906d452ec590732a93b051f3827e02749b83 $
    Database prefix: wp_

    ### WordPress constants ###

    ABSPATH: /var/www/html/wptest/
    WP_HOME: Undefined
    WP_SITEURL: Undefined
    WP_DEBUG: Disabled
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG_DISPLAY: Enabled
    WP_DEBUG_LOG: Disabled
    SCRIPT_DEBUG: Disabled
    WP_CACHE: Disabled
    CONCATENATE_SCRIPTS: Undefined
    COMPRESS_SCRIPTS: Undefined
    COMPRESS_CSS: Undefined
    WP_LOCAL_DEV: Undefined

    ### Filesystem permissions ###

    The main WordPress directory: Writable
    The wp-content directory: Writable
    The uploads directory: Writable
    The plugins directory: Writable
    The themes directory: Writable
    The Must Use Plugins directory: Writable

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    @gintsg Can you please confirm if you can see the noindex robots meta to the ngg_tag pages generated by the NextGen gallery plugin?

    @mazedulislamkhan I didn’t find any options in NextGen gallery where to set robots metas. So far my experience is that I did this just with Yoast SEO plugin.

    I did some additional test with all other Yoast SEO settings and fields for the tag page. Additional problem is, that the Custom Canonical link tag field not working as well. So, for specific NextGen gallery tag pages not rendered any data which you can define under Yoast SEO / Settings:
    – Allow search engines to show this Picture tag in search results?
    – Canonical URL
    And global settings under Search Appearance – Yoast SEO / Picture tag (ngg_tag) for:
    – Show Picture tag in search results?

    If I change Page Title, Meta Description etc. Then data from these fields are rendered properly. Only Canonical URL and Meta Robots tag not rendered. But the page is removed from the sitemap.xml page. You can see the updated page here:
    http://wptest.musicpm.lv/ngg_tag/test-tag/

    Both of these fields settings is not rendered on the tag page.

    • This reply was modified 1 year, 3 months ago by  gintsg.
    Plugin Support Michael Tina

    (@mikes41720)

    Based on the information you provided, we expect this to be a bug. We’re actively using the bug tracking on our GitHub repository so your best next step would be to create a new issue for our developers at https://github.com/Yoast/wordpress-seo/issues/new. You will need an account to create a new issue. If this is your first bug report, please check out: https://kb.yoast.com/kb/how-to-write-a-good-bug-report/.

    Don’t forget to include the URL to this conversation in your bug report.

    You may also want to create an issue or get support from the NGG team, or provide them the issue logged on GitHub in order to possibly speed up the review of this and to see what can be done to resolve it.

    Thank you! The issue report is created here: https://github.com/Yoast/wordpress-seo/issues/9402

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    Thanks for submitting the bug report. Our developers will now investigate this issue further. You can follow the progress of the bug report directly on GitHub.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘ngg_tag pages indexation’ is closed to new replies.