Support » Plugin: WordPress Gallery Plugin - NextGEN Gallery » NGG conflicts with The Events Calendar

  • Resolved dansart

    (@dansart)


    Howdy

    I found a Bug when NGG ist used in a The Events Calendar (Tribe Events) post.
    When the Shortcode is used in a Post of this type, the Javascript Error console shows this message:

    tribe-events-bar.min.js?ver=4.7.4:1 Uncaught TypeError: _.html(...).insertBefore is not a function
        at HTMLDocument.<anonymous> (tribe-events-bar.min.js?ver=4.7.4:1)
        at i (jquery.js?ver=1.12.4:2)
        at Object.fireWith [as resolveWith] (jquery.js?ver=1.12.4:2)
        at Function.ready (jquery.js?ver=1.12.4:2)
        at HTMLDocument.K (jquery.js?ver=1.12.4:2)
    (anonymous)	@	tribe-events-bar.min.js?ver=4.7.4:1
    i	@	jquery.js?ver=1.12.4:2
    fireWith	@	jquery.js?ver=1.12.4:2
    ready	@	jquery.js?ver=1.12.4:2
    K	@	jquery.js?ver=1.12.4:2

    Same Bug happens with every Theme i tried and only above NGG 3.0.16
    Any ideas how to fix that?

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support mihai-imagely

    (@mihaiimagely)

    Hi @dansart,

    Let’s first check to see if there is a multiple plugin conflict happening. Temporarily deactivate all plugins, then reactivate NextGEN Gallery only. Does the issue still appear? If so, temporarily switch to a WordPress default theme (this deactivation is only intended to quickly check to see if the issue goes away or is still present). If by deactivating the other plugins the issue does go away, reactivate each of the other plugins one at a time to locate the culprit. Keep me posted on your results 🙂

    Mihai

    Thread Starter dansart

    (@dansart)

    Hey Mihai

    Thanks a lot for your reply.
    I deactivated all Plugins except for the Events Calendar.
    Used the Default Theme and no modifications.
    So the error happens only on the Event posts.
    On all other Sites it works well.

    Plugin Support gabyimagely

    (@gabyimagely)

    Hi @dansar!

    Let’s check the server settings to make sure you have everything up to date. Reach out to your hosting provider and confirm they have thehttps://WordPress.org/about/requirements/ settings in place:

    MySQL v5.6 (or higher)
    PHP 7.3 (or higher)
    Memory limit: 250MB (or higher)
    Upload limit: 50MB (or higher)
    Post limit: 50MB (or higher)

    /wp-content directory has sufficient permissions (i.e. 755)

    With those in place, everything should work smoothly for you. If the issue still shows up, we’d like to take a closer look at this conflict with Event Calendar. We may need to deactivate plugins and switch the theme while troubleshooting temporarily. Would you feel OK with that? If so, please send us a bug report here: http://www.imagely.com/report-bug, refer back to this forum thread and let them know Gaby referred you.

    – Gaby, Customer Support.

    Thread Starter dansart

    (@dansart)

    Hey Gaby

    Thanks for your answer.
    I checked everything above and i still get the Error.
    I’ve sent a Bug report, hope this helps…

    Thanks,
    Daniel

    Plugin Support gabyimagely

    (@gabyimagely)

    Hi @dansart

    We have received your bug report.
    Thank you so much for sharing this informations and detailed steps to reproduce the problem. We truly appreciate it.
    ​We’ll be writing you back.

    – Gaby, Customer Support.

    Plugin Support gabyimagely

    (@gabyimagely)

    Hi @dansart

    Couldn’t thank enough for those instructions.
    It was easy to replicate.

    We have already created a bug report to our developers
    Please keep in mind that our developers need to address these issues in order of priority.

    Again, Thank you.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘NGG conflicts with The Events Calendar’ is closed to new replies.