Support » Plugin: NinjaFirewall (WP Edition) - Advanced Security » NF blocking me on Multisite

  • Resolved Michael

    (@mkalina)


    Hi, I have a multisite-network with NF (newest version) enabled. I log in to a subsite (which runs in a subdomain), hover over My Network > Administration > and then click on Settings. NF blocks me with this line in the log:

    09/Mar/17 10:00:00 #8499948 high 310 123.456.789.000 GET /wp-admin/network/settings.php – Access to a configuration file – [SERVER:SCRIPT_NAME = /wp-admin/network/settings.php] – DOMAIN

    However, if I click my way through the same path, NF does not block me.

    There is no session error.

    • This topic was modified 2 years, 7 months ago by  Michael.
Viewing 1 replies (of 1 total)
  • Plugin Author nintechnet

    (@nintechnet)

    Hi,

    I can reproduce the problem: The issue is that when you log in to the sub-site, the PHP session used to whitelist you is valid for that sub-domain only. When you access the My Sites > Network Admin > Settings, you are accessing the main site. That is no longer the sub-domain and hence you are not whitelisted (unless you logged in to the main site prior to log in to the sub-site). That is the way PHP session works, I can’t change that.
    I added this issue to my bug report, hopefully we’ll find a way to solve it one day!

    You are blocked by the rule 310, which you can disable if it is an annoyance.

    • This reply was modified 2 years, 7 months ago by  nintechnet.
Viewing 1 replies (of 1 total)
  • The topic ‘NF blocking me on Multisite’ is closed to new replies.