WordPress.org

Forums

NextGEN Gallery
[resolved] NextGen - wound up with two instances after upgrade to 2.0.59 (6 posts)

  1. Jay_SCT
    Member
    Posted 1 year ago #

    After resolving some of the conflicts with getting Nextgen 2.0.59 settled, I now see it loaded two instances of the plugin in my plugins list. I have one deactivated, and the other one running. Can I delete the one and assume the active one will remain?

    I'm not upgrading to 2.0.61 yet, given some of the issues out there.. but I don't want an issue trying to upgrade when I do. Are the two instances of it being installed separate or the same?? :-(

    Jay S.

    https://wordpress.org/plugins/nextgen-gallery/

  2. photocrati
    Member
    Plugin Author

    Posted 1 year ago #

    @Jay_SCT - The only way I can think of you having two separate entries in your Plugins list is if you have two separate folders for NextGEN Gallery on your server.

    The correct folder is /nextgen-gallery/ ... I would suggest making a verified backup of your site (JIC); deactivating the (both?) NextGEN Gallery plugin; and, then removing the "wrong" folder via FTP.

    Refresh the plugins list and the second instance should no longer show ... you might need to do a few refreshes or a hard refresh (or two). Reactivate NextGEN Gallery and check that things are working correctly with the version you have (I would expect so but just to be safe) ... then update to the current version.

    IF things go sideways, you have your backup you can restore; and send us a Bug Report (http://www.nextgen-gallery.com/report-bug/) so we can get a closer look at what may have happened.

    Thanks!

    - Cais.

  3. Jay_SCT
    Member
    Posted 1 year ago #

    Cais..

    Will do. I had to do the install of 2.0.59 via FTP replace (normal update kept failing - was one of those lucky people), so perhaps somewhere in the process another folder was created.. Thanks for the pointer.. will check and see and report back.

    Jay S.

  4. photocrati
    Member
    Plugin Author

    Posted 1 year ago #

    @Jay_SCT - Thanks!

    - Cais.

  5. Jay_SCT
    Member
    Posted 1 year ago #

    @Cais - sure enough Cais, there was a second folder there with a name of "backup-nextgen-gallery" which I have no clue on how it got there. As I mentioned, I had unzipped the files for 59, then had to use filezilla FTP client to install 59 to get past some of the error with the latest WordPress. I can fill out a problem report, but I cannot say how the backup gallery appeared. I did make a back up of the original Nextgen, but I called it Original Nextgen, and deleted it via FTP, once I knew 59 went on clean..

    Given some of the post reads, I'm a little hesitant on 61. I may wait to see if a 62 is coming soon. :-) Thanks for the help, and let me know if you still want a problem report.

    Jay S.

  6. photocrati
    Member
    Plugin Author

    Posted 1 year ago #

    @Jay_SCT - I would expect updates should progress smoothly now ... I would still suggest updating when you are comfortable. It will likely be a couple of weeks at least before the next release is out but the current version has necessary WordPress 3.9 compatibility code in it so you will need to eventually update. I recommend sooner rather than later just in case something unexpected does happen.

    Thanks!

    - Cais.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • NextGEN Gallery
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.