Support » Plugins and Hacks » [Resolved] Nextgen is requesting the wrong URL adress

[Resolved] Nextgen is requesting the wrong URL adress

  • Hi. I’m working on local server and sometimes I need to use ngrok service in order to put my local server online. So, I receive a custom ngrok URL and then I go to my wordpress and change the site URL. The fact is when I change the URL to http://localhost/wordpress again, Nextgen doesn’t reconigze it and keep using the previous URL. I think my Lightbox effect isn’t working because of this issue.

    My currently URL is http://localhost/wordpress . I checked the source code of a page and I could see Nextgen is using the previous URL http://335d780b.ngrok.com/wordpress


    <script type=’text/javascript’ src=’http://335d780b.ngrok.com/wordpress/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/lightbox/

    nextgen_lightbox_loading_img_url = “http:\/\/335d780b.ngrok.com\/wordpress\/wp-content\/plugins\/nextgen-gallery\/products\/photocrati_nextgen\/

    Why doesn’t Nextgen understand that I have changed the URL? Is there something I can do?



Viewing 15 replies - 1 through 15 (of 29 total)
  • Hello, i have the save issue here.
    The wordpress site was moved to anther domain. Everything works and the old domain was removed from the hole mysql dump.
    The only problem i have is the lightbox

    nextgen_lightbox_loading_img_url = "http:\/\/old-domain.tld\/wp-content\/plugins\/nextgen-gallery\/products\/photocrati_nextgen\/modules\/lightbox\/static\/jquery.lightbox\/lightbox-ico-loading.gif";
    nextgen_lightbox_close_btn_url = "http:\/\/old-domain.tld\/wp-content\/plugins\/nextgen-gallery\/products\/photocrati_nextgen\/modules\/lightbox\/static\/jquery.lightbox\/lightbox-btn-close.gif";
    nextgen_lightbox_btn_prev_url = "http:\/\/old-domain.tld\/wp-content\/plugins\/nextgen-gallery\/products\/photocrati_nextgen\/modules\/lightbox\/static\/jquery.lightbox\/lightbox-btn-prev.gif";
    nextgen_lightbox_btn_next_url = "http:\/\/old-domain.tld\/wp-content\/plugins\/nextgen-gallery\/products\/photocrati_nextgen\/modules\/lightbox\/static\/jquery.lightbox\/lightbox-btn-next.gif";
    nextgen_lightbox_blank_img_url = "http:\/\/old-domain.tld\/wp-content\/plugins\/nextgen-gallery\/products\/photocrati_nextgen\/modules\/lightbox\/static\/jquery.lightbox\/lightbox-blank.gif";

    I don’t find nothing in files or in the database to change this url.

    I hope someone can help here…



    Menu Gallery : “Other Options” => “Lightbox Effects” => (Show Advanced Settings)

    then change the domain, that’s all !!



    Hello mpluss,
    i did check this. but the url was correct.
    Now i did save it again, but the url still show the old domain.



    I’m having this problem as well. So far, I can’t find the domain referenced in the options table or any source. I am not using any custom local templates.

    The router uses $_SERVER['SERVER_NAME'] – I wonder if this value is affecting the result erratically in my current hosting environment.



    My second theory, as of yet unconfirmed, points to the use of records in the posts table (not registered as proper custom post type) with the post_type of display_type.

    I’m not sure why the folks at Photocrati decided to shoehorn this non-standard hack into the settings storage of the redesigned NextGEN plugin.. At this point, my only real concern is how to fix it.



    I was close.. It was a lightbox_library post_type. I wrote a script which will help fix the problem. It requires some knowledge of PHP – use it at your own risk!




    Hello deltafactory.

    You make my day!!!
    Your script fixed the issue… Thank you very much.



    You’re quite welcome. I’m glad it worked!

    Excellent is little to highlight your work!

    Thanks for your beatiful help!!

    Plugin Author photocrati


    @deltafactory – Thank you very much for sharing your script!

    – Cais.

    This works like a charm and is super simple to use.

    Thank you deltafactory!

    Thank you Deltafactory – much appreciated here and this resolved my issues also. Basically moving from my test site to this live site meant I got caught with old URLs and the “Search and replace” plugin did not catch these URL’s. Mayb nextGEN can release a fix for this soon as its a tricky one to find to be honest.

    Great! Search and replace won’t find it because the important values are stored inside of a non-registered custom post type as a serialized and then base64-encoded string. The result of encoding is garbled-looking text.

    Since a member of photocrati commented on this thread last week I’m hoping that they’re fully aware of the cause _and_ resolution of the problem and can roll a proper fix into future releases.

    Wow, thank you mpluss. You saved me from half a day of hair-pulling. (And I don’t have any hair!!!)

    no fix yet it seems in the last few releases now so this script in this thread is crucial. Thank you

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘[Resolved] Nextgen is requesting the wrong URL adress’ is closed to new replies.