Support » Plugins » Nextgen is requesting the wrong URL address (2?)

  • Resolved D. G.

    (@dgdodo)


    I face the same issues as mentioned here.

    [Unnecessary comments moderated]

    Although it looks like everything is working, the site takes ages to initial load, and it is mentioning the old URL during this initial site load?

    Clean WordPress install / 1 Plugin = NextGen.

    Linux Wheezy 7.4 / WP 3.8.1 / NextGen 2.0.40

    Tried to remove the NextGen plugin and reinstall it, the old URL’s get back???
    The db ‘holds’ the old values ‘somewhere’ ….

    Within the NextGen options, changed the settings, hit the SAVE button.

    http://dolfgeerdink.dyndns.org/DGWP01/wp-content/uploads/2014/02/img_530e09e14b192.png

    What does the SAVE button save, because the old values are still there?
    (sorry mpluss, your solution does NOT help me, the same as Space2Place.
    The URL is NOT changed although the page says ‘Saved succesfully’.)

    Tried the php fix of deltafactory (https://gist.github.com/deltafactory/6789297).
    Also this fix, does NOT change the following URL’s:
    – Stylesheet URL
    – Javascript URL
    Tried this with the plugin active or inactive, no changes are made.

    photocrati: it would be nice if you inform everybody here which solution you sent privately to Joao Calheiros (I sent a reply back to your Bug Report..)
    I still can’t change the old URL’s within the NextGen settings.

    How the …. you can change these?
    Even checked the DB, nowhere these URL’s can be found (or changed).
    Any other solution ready yet? Its getting annoying, this.

    This 1 page site is a memorial: LINK

    Regards, DG.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Just to mention that also the video did not help me:
    http://www.nextgen-gallery.com/galleries-opening-lightbox/

    After a successful save, checking the values: still the old values there, and an aging initial load (with the old ipadress waiting in the status bar) of the site.

    Additional info?

    Operating System : Linux (32 Bit)
    Server : Apache/2.2.22 (Debian)
    Memory usage : 12.54 MByte
    MYSQL Version : 5.5.35-0+wheezy1
    SQL Mode : Not set
    PHP Version : 5.4.4-14+deb7u7
    PHP Safe Mode : Off
    PHP Allow URL fopen : On
    PHP Memory Limit : 128
    PHP Max Upload Size : 2M
    PHP Max Post Size : 8M
    PCRE Backtracking Limit : 1000000
    PHP Max Script Execute Time : 30s
    PHP Exif support : Yes ( V1.4 )
    PHP IPTC support : Yes
    PHP XML support : Yes
    Graphic Library
    
    GD Version : 2.0
    FreeType Support : Yes
    FreeType Linkage : with freetype
    T1Lib Support : No
    GIF Read Support : Yes
    GIF Create Support : Yes
    JPEG Support : Yes
    PNG Support : Yes
    WBMP Support : Yes
    XPM Support : No
    XBM Support : No
    JIS-mapped Japanese Font Support : No

    This could be related that db and site are indeed moved to other server.
    Within source code i even see ip-addresses from before the last move!

    Regards, DG.

    P.S. Pitty however that after a moderation of this topic, I can not edit the original tread anymore?

    Fixed these wrong url settings with:

    NOTE: All galleries / pages / posts / comments will be gone!!

    WordPress Reset
    —————
    Resets the WordPress database back to it’s defaults. Deletes all customizations and content. Does not modify files only resets the database.

    Version 1.3.3
    By Matt Martz

    Needed to re-create the gallery again, but its only 1 and simple gallery.
    Closed topic.

    DG.

    P.S. Admin / moderator: Please remove the last LINK in the initial topic? i can NOT edit this topic (after moderation)?

    esmi

    (@esmi)

    Forum Moderator

    It is not the general policy to edit or delete forum posts. When a post is made and people contribute answers to an issue, that then becomes part of the community resource for others to benefit from. Editing or deleting posts removes this added value. In extreme circumstances, the moderation team might be persuaded to remove sensitive information but. generally, your best course of action is not to publish anything that you wouldn’t want to be public.

    http://codex.wordpress.org/Forum_Welcome#Deleting_.2F_Editing_Posts

    I’m sorry but this is not an extreme case.

    esmi,

    It not that bit issue indeed. The link however points to just a (memorial) page and was not suppose to be public, in this way. As you adjusted my earlier reply, i thought you could also just remove the link in my new topic.
    No bother as this is too much work …

    Furthermore:
    I just wrote my information and findings with NextGen plugin for anyone as informational, also for u (and your colleagues).
    It’s just that i found these strange settings within my (copied) wordpress instance with nextgen. And discovered a rather long delay in initial loading of the page. As some of the people did have fixed their problem with it, i did not.
    But i found, and gave ‘a’ solution, so put this topic on resolved.

    Best practice would be:
    Don’t copy complete worpdress / Nextgen folder(s) to new location!
    – Do a New install of Nextgen within wordpress on new location
    – Copy only the gallerie-maps to new location
    – import galleries within new nextGen instance.

    Regards, DG.

    P.S. But there’s probably even better manual elsewhere 🙂

    This was my situation in quick:

    1. Moved wordpress & wordpress-db (mysql) to new machine.
    2. Changed settings in wordpress to point to new location.
    3. Most links were changed according the new location/name.

    The following ‘old’ links (Gallery / Other options / Lightbox / Show Advanced Settings / Fancybox) were still there and could not be changed anyway.
    Not with the ‘save’ function mentioned in the video. they stay at the old value.
    Also tried the php fix of deltafactory (https://gist.github.com/deltafactory/6789297), which did change some, but not all URL’s.

    – Stylesheet URL
    – Javascript URL (3x)

    As it occured on a simple 1 page site, i decided to run http://wordpress.org/plugins/wordpress-reset/

    NOTE: All galleries / pages / posts / comments will be gone!!

    Could import all images, they were not deleted. Re-created gallery and checked the settings.
    All URL’s are pointing to the correct location now.
    And setup the old page up again (loading much quicker, as it is not checking the wrong url’s anymore!).

    Hope it will help others and-or your development team to overcome this issue in the future.

    Regards, DG.

    Based on deltafactory’s code, change all urls:
    https://gist.github.com/iamzozo/9668382

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Nextgen is requesting the wrong URL address (2?)’ is closed to new replies.