Support » Plugin: WordPress Gallery Plugin - NextGEN Gallery » Nextgen gallery uses http links instead of https

  • Resolved ruslany

    (@ruslany)


    If I request a home page of my site the browser displays the address of my site as non-secure. This is because all the links generated by NextGen gallery plugin still use http:// instead of https://. This is only a problem when requesting a home page; if I request any individual posts then the links are correctly using https://.

    I saw a similar question posted before https://wordpress.org/support/topic/nextgen-gallery-conflict-with-ssl/, but in my case I do not have any other plugins except NextGen Gallery and Yoast SEO.

    I tried to clear the cache and it helps, but after some time the NextGen again reverts to using http:// on the gallery links in the home page.

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Plugin Support gabyimagely

    (@gabyimagely)

    Hello @ruslany

    Apologies, but the forum thread that you shared is outdated.
    We currently don’t have any reports regarding our plugin being unable to use your SSL certificate. If possible, please check if your SSL certificate is valid and if you are forcing SSL in your site.

    Here is an excellent guide you can use:
    How to Properly Move WordPress from HTTP to HTTPS (Beginner’s Guide)
    https://www.wpbeginner.com/wp-tutorials/how-to-add-ssl-and-https-in-wordpress/

    Please, let us know if that worked for you.
    We are happy to help!

Viewing 1 replies (of 1 total)
  • The topic ‘Nextgen gallery uses http links instead of https’ is closed to new replies.