NextGEN Gallery: Tables could not created, please check your database settings (10 posts)

  1. rfarrell
    Posted 6 years ago #

    ef: NextGEN Gallery: Tables could not created, please check your database settings

    I have researched the blog and see this error in several posts without a description how it is resolved.

    NextGEN Gallery : Tables could not created, please check your database settings

    Tables ARE created including (blogname)_ngg_album, (blogname)_ngg_gallery, (blogname)_ngg_pictures

    I have restarted my server (which would restart mySQL).

    If I "deactivate" then "activate", I get the above message and the "Plugin Activated" at the same time.

    I am using mySQL 5.1.57-community on a Windows 2k3 Server. WP is running under IIS and not apache and the Atahualpa theme. I have tried other themes and deactivating all other plugins.

    Thanks in advance for troubleshooting advice.

  2. Alex Rabe
    Posted 6 years ago #

    Check the access rights for the sql user (setup in wp-config.php), maybe this user can't create tables

  3. rfarrell
    Posted 6 years ago #

    Hello; Thanks for your help!

    I have checked the MySQL database username 'DB_USER', '[myusername]' specified in wp-config and it has ALL PRIVILIGES for the database. And, the tables [datbasename]_ngg_album, [blogname]_ngg_gallery, [datbasename]_ngg_pictures ARE being created where [datbasename]_ is the database name (see screenshot below). These tables are also dropped when I uninstall the plugin. The DB_HOST is specified as 'localhost' which appears to run successfully for WP and all other plugins I have tried.

    Here is a screenshot of the two messages:

    And, here is a screen shot confirming permissions and the databases:

    Best, Richard

  4. 67ss
    Posted 6 years ago #

    I'm in the same boat... same server config, etc. Tables actually get created / deleted as you mentioned but for whatever reason NextGEN can't see them. I'm *guessing* it's a permissions issue of some sort; but I can't seem to find it.

    Any luck?

  5. sandra2
    Posted 5 years ago #

    I have also the problem. The tables were created. So it cannot be an access and "create table" problem.

    I use 2.9 wordpress

  6. smumdax
    Posted 5 years ago #

    Same problem here also... can anyone help !?

  7. smumdax
    Posted 5 years ago #

    I finally managed to find a solution... on a Spanish website! Geez...

    This might help someone else, so here's where I found a hint to help solve:

    From what I understood, the plugin tries to create tables in the form of a standard WordPress installation, in which tables are named with the suffix "wp_".

    However, in my case (and probably others), I have multiple Databases and some with other WordPress installations, and so the prefix isn't the same for all. The prefix for this particular WordPress Database is "mob2_"... and so, the plugin couldn't create the tables in the form "wp_" and therefor couldn't find his tables after activating the plugin.

    So what I did was to copy the entire CREATE TABLE codes in the link above. Then I went to phphMyAdmin to find my database. In there, I sent out the query. All tables were created successfully. I then renamed the tables changing prefix "wp_" for my own "mob2_".

    After that, my plugin still gave me the error, but all the gallery menu worked. So I deactivated and reactivated the plugin.

    Error gone :)

    Hope all this is clear and will help someone else!

  8. dogbot
    Posted 5 years ago #

    One more addition: I was having this problem and not even the instructions above where working. but then I relized that the problem was the way I was prefixing all of my WP installations
    they all are wp_somename_

    When I changed the prefix (reinstalled WP) to somenamewp_ the problem went away.

    So that first "wp_" was tripping it up

  9. The J
    Posted 5 years ago #

    This could be a bug because Im having the same problem and there is nothing wrong with either my db user or my config.

    I posted the issue in this other thread http://wordpress.org/support/topic/298493?replies=5#post-1446718 please someone have a look at the issue.

    Thank you

  10. DariusKM
    Posted 5 years ago #

    I had the same issue and kind of managed to sort it out in a different way as the above method didn't work for me.

    It is all in this other thread:


    Hope that it helps someone.


Topic Closed

This topic has been closed to new replies.

About this Topic