WordPress.org

Forums

NextGEN Gallery
NextGen Gallery Slideshows require the Flash Player (10 posts)

  1. trotterellone
    Member
    Posted 1 year ago #

    Hello, after updating to the last version NextGen Gallery and WordPress, I have this error:

    Slideshows require the Flash Player and a browser with Javascript support.

    I followed: Disable in the gallery options -> slideshow "Try XHTML validation" but This was already unchecked in my settings, so I checked it and unchecked again, no change.

    How I solve?

    http://wordpress.org/plugins/nextgen-gallery/

  2. photocrati
    Member
    Plugin Author

    Posted 1 year ago #

    @trotterelione: The flash slideshow player is bundled with NG, so it's already there. I'm not sure why you are seeing that message.

    As a quick fix, you can convert your slideshows to non-flash slideshows. That will obviously solve the problem, though you'd lose flash functionality.

    The next thing I'd try is just deactivating all your other plugins for a moment and seeing if that makes it go away. If so, you can still just immediately reactivate all your plugins and then try deactivating one by one until you find the culprit.

    Can you also post a link to the page so we can see it?

    Thanks,
    Erick

  3. dcutri500
    Member
    Posted 1 year ago #

    The flash player is working great for me, 1330px wide by 450px high. But I need the slideshow to work on an iPhone. So, I turn flash off, but then my slideshow dimensions are completely ignored. It won't stretch wide like i want it. The only way I can get the slideshow to match the dimensions I want is in flash mode, which i can't have. What am I doing wrong? kbhomedesign.com

  4. dcutri500
    Member
    Posted 1 year ago #

    Ugh! Why won't it stretch to full width?!! It just wants to be at 600x400 and that's it. Very frustrating. Any help would be appreciated. If the "under construction" page is showing, that's because I don't want the site seen right now, but I can open it up if you'll help me: http://kbhomedesign.com

  5. dcutri500
    Member
    Posted 1 year ago #

    When I enable flash, it's just beautiful, but like I said, I can't use Flash. If I turn off Flash and then change the CSS for the images from:

    .ngg-slideshow img {
    max-width: 100% !important;
    max-height: 100%;
    width: 100%;
    height: 100%;
    }

    to

    .ngg-slideshow img {
    max-width: 100% !important;
    max-height: 100%;
    width: 100%;
    height: auto;
    }

    then the images will stretch to the width I want, but they get squashed vertically. If I remove the max-height, then they don't get squashed, but they are vertically misaligned. How do I get the images to behave the way they do when Flash is enabled? Of course, I don't mind losing vertical area to avoid the squashing, but they need to be centered.

    Any help?

  6. dcutri500
    Member
    Posted 1 year ago #

    Then I tried to reset the NextGen settings, and my whole site disappeared. Luckily I had a recent backup. Then when I restored there were several problems throughout the entire site. I deleted the plugin and all files, and everything went back to normal again, so I can only assume... There is no way I will be reinstalling and trying again. I never had any trouble with the old version of NextGen Gallery. That's what I'm gonna use.

  7. photocrati
    Member
    Plugin Author

    Posted 1 year ago #

    @dcutri500: Flash slideshows are not mobile friendly in general. And regular slideshows just obey the the size settings you set under Gallery Settings > Basic Slideshows, or when you add the gallery via the ATP interface. They are not designed to expand to full width on mobile devices.

    I also want to confirm: When you reset your options, did you just get blank white pages?

  8. dcutri500
    Member
    Posted 1 year ago #

    No, it literally deleted the entire site. I forgot what specific error it was, but it was whatever happens when there are no files at all on the server. I know I can't use Flash for mobile devices, but I was hoping that it would be adaptive so that Flash would be used for the desktop browsers and regular slideshows would be shown on mobile devices. I reverted back to Version 1.9.13 and now everything is working the way I want. No offense, but I'm afraid to try again with the new version. Maybe in the future on another site when I am not under the gun (a deadline).

  9. processit
    Member
    Posted 1 year ago #

    I´ve updated yesterday an receive the same error. Deactivating other plugins didn´t help.

    See: http://www.poster4nature.com

  10. sandrogod
    Member
    Posted 1 year ago #

    I realized the mistake, I was using thickbox in conjunction with NextGen. I disabled it(thickbox), returned to normal.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • NextGEN Gallery
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.