WordPress.org

Support

Support » Plugins and Hacks » NextGen gallery: Singlepic: Alt-text displayed. No image.

NextGen gallery: Singlepic: Alt-text displayed. No image.

  • LostInNetwork
    Member

    @lostinnetwork

    I have a strange problem: NextGen Gallery _suddenly_ ceased to show embedded images both on static pages and in the blog. I did not touch a thing…

    The [singlepic] thing seems broken. It only shows the alt-text.

    The created link works, and shows the image once clicked. Galleries, albums, everything works – except IMG tags.

    This happens on Vista (Firefox and IE) and Ubuntu (Firefox). Several people have confirmed the problem.

    ————————————————
    NextGen gallery creates the following URL:
    /wordpress/wp-content/plugins/nextgen-gallery/nggshow.php?pid=20&width=160&height=120&mode=

    using:
    [singlepic=20,160,120,,left]

    Picture 20 exists in a gallery.

Viewing 15 replies - 1 through 15 (of 39 total)
  • LostInNetwork
    Member

    @lostinnetwork

    I just remembered that NGG was updated a while ago…
    Maybe that broke the singlepic feature?

    Can you add a link for an example ? Check if you can call the nggshow.php file manually…

    symmetrium
    Member

    @symmetrium

    I have exactly the same problem.

    Galleries are displayed fine, yet single image post, the image browser, etc. do not work.

    I think it’s a theme conflict. There are no problems when the “fastway” theme is used, yet this problem occurs when I switch back to my regular theme.

    Swithing all plugins (except nextgen gallery) off did not change anything, the result is consistent in opera, firefox, and ie7.

    When I isolate the image address and paste it into the address bar I only get a blank page with the following text:

    http://symmetrium.org/wp-content/plugins/nextgen-gallery/nggshow.php?pid=12&width=&height=330&mode=

    If i switch themes and do the same, I do actually get the image.

    Here‘s a link for example of the situation.

    Thank you very much in advance for any tips.

    looks good from here, anything changed ?

    nathanielsandell
    Member

    @nathanielsandell

    My single pictures don’t show up either.
    The code looks like this:
    ‘<h3>P1020224.JPG</h3>
    <div class=”pic”>

    <img alt=”P1020224.JPG” src=”…/wp-content/gallery/uncleb//P1020224.JPG%20title=” uncle=”” jj=”” and=”” auntie=”” sin's=”” wedding=”” photo=””>

    </div>’

    I don’t know if the double // matters before the name of the picture.
    Notice the %20 instead of an end quote?
    When I took the page code and put it in post, the picture was displayed (as opposed to the alt text).
    An example of the working code in a post:
    http://is.gd/9Sn

    Where do I fix the code so the src link ends in a ” instead of %20?

    Thanks in advance for the help.

    Try to remove the slash in the gallery path (See manage Gallery – edit gallery)

    symmetrium
    Member

    @symmetrium

    yeah now it looks good because – sorry for my impatience – I switched to another theme!…

    [just for the sake of it I checked out the gallery path and there was no slash at the end of it. I even tried adding one – to no avail… :/]

    It’s really strange, to me it really looks like it’s the theme that interferes with nggshow.php

    When I save the faulty page (where the pic doesnt show) as html and switch the theme on my site (to the theme that does not have problems) and then open the saved page (the html that is on my hard disk and that carries the faulty theme) the picture does show up.

    It seems that that there is something in the theme that doesn’t let nggshow.php do its job properly and causes it to return the image’s address in firefox (and an empty image box on ie7) instead of the actual image… Is that a possibility?

    (I hope that what I wrote does makes sense and helps…!)

    nathanielsandell
    Member

    @nathanielsandell

    I removed the double slash by removing the end slash in the gallery settings. Thanks.
    But, the picture still doesn’t show up because the src link still ends in a %20 instead of a “.

    <img alt=”P1020193.JPG” src=”http://nathanielsandell.com/blog/wp-content/gallery/uncleb/P1020193.JPG%20title=” uncle=”” jj=”” and=”” auntie=”” sin's=”” wedding=”” photo=””>

    Is this a problem with my theme? I would prefer not to switch themes. This seems like an easy problem to fix if I knew where this code was generated.

    Please disable first all other plugins and check the behaviour again…

    nathanielsandell
    Member

    @nathanielsandell

    You were right. It was my “SEO Friendly Images” plugin.
    It works fine now.
    Thanks for the help.

    Hi, I have same problem with singlepic option. I’ve read and tried all above and nothing happens. I disabled all plugins instead of NextGen and didn’t helped.

    Then I’ve tried to switch theme and used WordPress basic theme and the samo thing again.

    As someone else allready wrote, when I use singlepic option I get url like this http://nisdance.com/cms/wp-content/plugins/nextgen-gallery/nggshow.php?pid=90&width=100&height=75&mode=

    On my other website everything works fine (there are many more plugins than here).

    I use [singlepic=90,100,75,,left]

    URL that you can take a look is http://nisdance.com/

    Regards, Milan

    I’m having the exact same problem as kwisko. This is only for singlepic, I’ve gotten other things to work just fine. I have a custom theme. My url for the image looks very similar to kwisko’s. Has anyone figured out what is causing the problem?

    I have a similar problem. In IE6 the pic inserted into my post with the NextGen button works fine. But in Firefox2 it looks like a 10x10px pic instead of the 320x240px as specified by the NextGen code [singlepic=4,320,240,,left].

    My site is at BikingTrails.com.au and the post for 7th July shows the problem. The previous posts had to have an IMG tag hardcoded as I couldn’t get NextGen to display the pic properly.

    The resultant IMG & link code generated on the page is:

    <div class=”ngg-singlepic-wrapper ngg-left”><img class=”ngg-singlepic” src=”http://bikingtrails.com.au/wp-content/plugins/nextgen-gallery/nggshow.php?pid=4&width=320&height=240&mode=” alt=”wa-perth-fire-engines-01.jpg” title=”wa-perth-fire-engines-01.jpg” /></div>

    Any help to show the image at correct size would be appreciated.

    same prob over here since a few days…
    anything works fine expect the singlepics….

    a solution pls…..
    thnx

    Hi,

    I’ve also got this problem. WP 2.5.1 NG 0.97

    See http://www.bigred500.co.uk/?p=10

    If you click on the displayed image name the slideshow works fine.

    Generated code

    <p><a href="http://www.bigred500.co.uk/wp-content/gallery/post-pictures/img_4776_1_1.jpg" title="I've now got two keys" class="thickbox" rel="singlepic11" ><img class="ngg-singlepic" src="http://www.bigred500.co.uk/wp-content/plugins/nggallery/nggshow.php?pid=11&amp;width=400&amp;height=400&amp;mode=" alt="img_4776_1_1.jpg" title="img_4776_1_1.jpg" /></a></p>

    and targetting nggshow.php directly using this url

    http://www.bigred500.co.uk/wp-content/plugins/nggallery/nggshow.php?pid=11&amp;width=400&amp;height=400&amp;mode=

    displays the exact same URL in the browser window. The interesting thing is that in FF3 with HTML validator you can see that the page content is actually a .jpg file and the tab name is “nggshow.php (JPEG Image)”

    It’s like the thumbnail .jpg data stream is corrupt?

Viewing 15 replies - 1 through 15 (of 39 total)
  • The topic ‘NextGen gallery: Singlepic: Alt-text displayed. No image.’ is closed to new replies.