WordPress.org

Support

Support » Plugins and Hacks » NextGen Gallery Powertags » [Resolved] [NextGen Gallery Powertags][1.6.1][ERROR] : You must specify at least one galler

[Resolved] [NextGen Gallery Powertags][1.6.1][ERROR] : You must specify at least one galler

  • Mauro,
    I’m adding my galleries via the “do_shortcode()” method and passing in a dynamic gallery ID as such:

    $gallery_id = (int)get_post_meta(get_the_ID(), 'gallery_id', true);
    
    	if($gallery_id) {
    		echo '<figure id="client_gallery">';
    		echo do_shortcode('[nggpowertags id='.$gallery_id.' template=galleryview-lazy images=50 exclude=black-and-white]');
    		echo '</figure>';
    	}

    If I set the shortcode as the default nextgen shortcode: “nggallery” this method works fine except the excluded images are shown, which I expect; however, if I set the shortcode as per the example above (using “nggpowertags“) then I receive the error:

    [NextGen Gallery Powertags][1.6.1][ERROR] : You must specify at least one gallery ID.

    Any thoughts as to why I can’t use a dynamic GalleryID?

    http://wordpress.org/extend/plugins/nextgen-gallery-powertags/

Viewing 1 replies (of 1 total)
  • Mauro,
    No worries, it was all my fault; I misread the attributes for the shortcode and missed that I needed to change “id” to “gallery“, as shown in the call ablove!

    It’s working perfectly now that I’ve made that switch and I hope this helps anyone else who runs into the same issue!

    Cheers,
    Jon

Viewing 1 replies (of 1 total)
  • The topic ‘[Resolved] [NextGen Gallery Powertags][1.6.1][ERROR] : You must specify at least one galler’ is closed to new replies.
Skip to toolbar