Support » Plugins » Nextgen-gallery, overlay problem?

  • Resolved Dragzonox

    (@dragzonox)


    Hello

    I’m using Nextgen-gallery version 0.96, with WordPress. I’m also using a flashplayer plugin (FLV Embed V 1.1), and I’m embedding videos from youtube, gametrailers, and so on…

    My problem is “simple”, when I use the thickbox plugin, and the image popups up, the flash player overlays it. You can see what I mean here. (just scroll down, so you can click on a screenshot, and see the flashplayer at the same time)
    How do I solve this?

Viewing 15 replies - 1 through 15 (of 15 total)
  • I have the same problem, did you ever solve?

    It isn’t a problem with NextGen or WP; it’s with Flash. This happens even when you overlap two flash videos: the one underneath distorts the one on top.

    Well i add this to the flash in my site and it works <param name=”wmode” value=”opaque”>

    @toro484: Very interesting. Thanks for the tip.

    This works in IE:) Is there a similar fix for Firefox? (doesn’t work there)

    Hi,
    on my FF3 its shows like it should. Cache has been cleaned?

    best regards
    bee

    I’ve tried. Could my code be faulty?:

    <object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,0,0" width="258" height="55" id="byggservice_white" align="middle">
            <param name="wmode" value="opaque" />
    	<param name="allowScriptAccess" value="sameDomain" />
    	<param name="allowFullScreen" value="false" />
    	<param name="movie" value="http://filipstad.ifolkmun.se/ads/byggservice/byggservice_white.swf" /><param name="quality" value="high" /><param name="bgcolor" value="#2046e8" />	<embed src="http://filipstad.ifolkmun.se/ads/byggservice/byggservice_white.swf" quality="high" bgcolor="#2046e8" width="258" height="55" name="byggservice_white" align="middle" allowScriptAccess="sameDomain" allowFullScreen="false" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" />
    </embed>	</object>

    I ran into the same issue and discovered that IE reads it from <param> tag while firefox reads it from <embed> tag. To fix you need to make sure it’s specified in BOTH tags.

    • IE: <param name=”wmode” value=”opaque” />
    • FF: wmode=”opaque”
      <object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,0,0" width="258" height="55" id="byggservice_white" align="middle">
              <param name="wmode" value="opaque" />
      	<param name="allowScriptAccess" value="sameDomain" />
      	<param name="allowFullScreen" value="false" />
      	<param name="movie" value="http://filipstad.ifolkmun.se/ads/byggservice/byggservice_white.swf" /><param name="quality" value="high" /><param name="bgcolor" value="#2046e8" />	<embed src="http://filipstad.ifolkmun.se/ads/byggservice/byggservice_white.swf" quality="high" bgcolor="#2046e8" width="258" height="55" name="byggservice_white" align="middle" allowScriptAccess="sameDomain" allowFullScreen="false" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" wmode="opaque" />
      </embed>	</object>

    i have the same problem,please can somebody help me.

    i have a javascript mp3 player on my site and when i active my nextgen gallery the pictures are showing behind the mp3 player.

    when i take a look of the javascriptcode i dont see the code wmode.

    this is my mp3 javascriptcode:

    <script type=”text/javascript” src=”swfobject.js”></script>

    <div id=”flashPlayer”>
    This text will be replaced by the flash music player.
    </div>

    <script type=”text/javascript”>
    var so = new SWFObject(“playerMultipleList.swf”, “mymovie”, “320”, “250”, “7”, “#ffffff”);
    so.addVariable(“autoPlay”,”no”)
    so.addVariable(“playlistPath”,”playlist.xml”)
    so.addVariable(“overColor”,”#fb05c4″)
    so.write(“flashPlayer”);

    </script>

    The solution was posted just above your reply:

    * IE: <param name=”wmode” value=”opaque” />
    * FF: wmode=”opaque”

    You just have to modify your script to add these two attributes

    Probably a dumb question, but where exactly are these tags located? Also, do I need to download the Thickbox plugin separately from NextGen gallery in order for Thickbox to work properly? The reason I ask is that NGG seemed to work the same before I ever uploaded the Thickbox plugin. I am still getting errors in IE 6 and 7, as well as Chrome since I uploaded Thickbox, Lightbox, and Highslide. I deactivated all of these since I was having more problems, but it seems like things are worse now with NGG than before I started uploaded these plugins.

    http://bvlrestoration.org

    I put this on another thread as well.

    I tried the Highslide plugin, but it seemed to create more problems. Even if I just activate Highslide, but continue to use the Thickbox option with NGG, I get different problems based on the browser I’m using:
    IE 7: most images are displayed with an overlap on the bottom
    FF 3: most images are displayed with an offset overlap, with the bottom picture offset to the right. When I close the image and click on the thumbnail again the image shows up fine.
    Chrome: same as Firefox 3.

    If I activate the Highslide plugin, and select the Highslide option within NGG, my images simply open up in a separate window in all the major browsers. It’s as though there is no plugin in use at all.

    I get similar results with the other plugins such as Lightbox. Keep in mind, I don’t have the Thickbox plugin installed and when I deactivate all the other image plugins, Thickbox for NGG works fine in FF 3.0 and Chrome, but has the same issue with IE7.

    Any suggestions?

    http://bvlrestoration.org

    mariostella

    (@mariostella)

    to bvlrp:
    There is no easier way than following c_swanky’s advice (thanks c_swanky!)
    Just copy and paste the code he wrote in your template then change the movie file location values and that’s it!

    What if I use openads for my flash banners? The invocation code looks like this:

    <script type='text/javascript'><!--//<![CDATA[
       var m3_u = (location.protocol=='https:'?'https://d1.openx.org/ajs.php':'http://d1.openx.org/ajs.php');
       var m3_r = Math.floor(Math.random()*99999999999);
       if (!document.MAX_used) document.MAX_used = ',';
       document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
       document.write ("?zoneid=8120&amp;target=_blank");
       document.write ('&amp;cb=' + m3_r);
       if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
       document.write (document.charset ? '&amp;charset='+document.charset : (document.characterSet ? '&amp;charset='+document.characterSet : ''));
       document.write ("&amp;loc=" + escape(window.location));
       if (document.referrer) document.write ("&amp;referer=" + escape(document.referrer));
       if (document.context) document.write ("&context=" + escape(document.context));
       if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
       document.write ("'><\/scr"+"ipt>");
    //]]>--></script><noscript><a href='http://d1.openx.org/ck.php?n=a3f866ea&amp;cb=INSERT_RANDOM_NUMBER_HERE' target='_blank'><img src='http://d1.openx.org/avw.php?zoneid=8120&amp;n=a3f866ea' border='0' alt='' /></a></noscript>

    I have a problem with this as well. When I use thickbox and click on the thumbnail so the image pops up the youtube clip in the background will overlay the image. Is it solvable with any of the methods suggested above? And if so, where and in what file do you put the code? I’m a bit desperate for help here. Thanks in advance!

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Nextgen-gallery, overlay problem?’ is closed to new replies.