WordPress.org

Forums

NextGEN Gallery Optimizer
NextGEN Gallery Optimizer Causing album galleries to display poorly (5 posts)

  1. jamminjames
    Member
    Posted 2 years ago #

    NextGEN Gallery Optimizer (not using premium version) is causing the galleries in my albums to display poorly. The thumbnail images do not display the way they should, and the gallery itself shows the thumbnails in a vertical row, instead of in horizontal rows, as it should be. The regular galleries (ones that are not part of any album) display properly.

    When I disable NextGEN Gallery Optimizer, the album galleries display correctly.

    I like the Optimizer, but this is unacceptable behavior. What can be done to fix this?

    http://wordpress.org/extend/plugins/nextgen-gallery-optimizer/

  2. Mark Jeldi
    Member
    Plugin Author

    Posted 2 years ago #

    Hi jamminjames,

    The original, Basic version of Optimizer you're using only supports the popular [nggallery id=x] shortcode, and thus, does not load the required scripts and styles for other NextGEN shortcodes (resulting in the unstyled vertical row of thumbnails you're seeing). This works great for most people, and is due to the fact I originally developed the code for a client with this specific requirement in mind.

    I later went on to develop the Premium version of Optimizer for users who liked the plugin and wanted support for extra shortcodes such as [album id=x]. If you require this extra functionality, a donation for the Premium version would be very much appreciated, as it helps sustain continued support and development.

    Cheers,
    Mark.

  3. jamminjames
    Member
    Posted 2 years ago #

    But your plugin is messing with the LOOK of the albums and galleries within. I don't mind that it's not optimizing them, but it shouldn't screw up my galleries.

    This is a very bad side-effect, and will probably end up costing you sales, so I would hope you would fix it, if only for your own benefit.

    The album and the galleries within it both display improperly, not the way I have them set up in NextGen. The thumbnails are supposed to display in rows, but your plugin is causing them to only show one thumbnail per row, very ugly.

    Other galleries that are not part of albums are displaying just fine.

    As I say, I don't mind that it doesn't OPTIMIZE the albums, just please fix it so it doesn't mess up how they DISPLAY.

    Thank you.

  4. Mark Jeldi
    Member
    Plugin Author

    Posted 2 years ago #

    Hi jamminjames,

    Thanks for your feedback.

    I'll look into your suggestion for a future release.

    Cheers,
    Mark.

  5. Monika
    Member
    Posted 2 years ago #

    I have the same effect, ugly albums - and so I can't use your plugin :(

    I'm waiting for an update, because the idea is fantastic!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • NextGEN Gallery Optimizer
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic