Support » How-To and Troubleshooting » nextgen gallery loses functionality

nextgen gallery loses functionality

  • HELP!

    Out of no where my Nextgen gallery has stopped functioning.
    1. The flash uploader does not work, but regular image uploader does.
    2. The tinymce button in the visual editor no longer works, instead, it brings up my website with a 404! error like it can’t find a page.
    3. The singlepic id= code is not working. Gallery id= works, but singlepic only provides a link of the file name instead of any preview. This is also the case when I insert a single pic via the Upload/Insert option and go to the nextgen tab.

    One problem seems to be that the [singlepic id=] code is no longer pointing to the gallery/cache folder where it generates the single pic images. In fact, I don’t know at what point those images are generated either!!!

    Can ANYONE please help. I can provide more details if necessary. Thanks.

    – Eric

Viewing 13 replies - 1 through 13 (of 13 total)
  • Alex PLEASE HELP!!! Are you out there??? This makes no sense and I have no where else to turn!

    A little further info. Yes, I have deactivated all other plugins and reset my cache several times… no luck.

    I have reinstalled the plug in (and did so before I knew about backing up my databases resulting in a LOT of work to relink all the galleries)… no luck.

    My administrator replaced the wp-admin and wp-includes folders. No luck.

    The source of the problem seems to somehow link the flash uploader, the tinymce button not working, and images not being generated in the gallery/cache folder for [singlepic id=] to link to.

    Worst of all, this simply happened between one log in and the next. Nothing was added, no new plug ins were downloaded… the entire site has only existed for about 3 months.

    More info. I tried this on a different computer and operating system with the same result. So it is NOT related to the computer I am working on.

    Some MORE info to help explain the really odd stuff going on.

    When using the Nextgen flash uploader, a folder is created in the gallery folder (I can see this on my FTP) but a series of ERROR : filename : 404 codes are shown for each image trying to upload, and then it says no images were added to the gallery. Sure enough, the gallery folder is empty.

    When using the regular Nextgen uploader this does not happen and all of the images are uploaded into the gallery.

    Try to add the [singlepic id=x] in html mode, not visual mode. sometimes it kicks it and it will work.

    Trying the [singlepic id=] code in html was one of the first things I did. I figured it would be an easy work-around. Didn’t work.

    It doesn’t work because the single pic images are not being generated in the cache folder. If I take the single pic code from an old post (that works) and copy and paste it into a new post it actually stops working. If I view the source code, it actually alters itself when pasted into the new post, and suddenly starts looking for images in a sub-directory of the plugins folder rather than in the gallery.

    Something is happening with where nextgen is referencing it sources because of all of these 404 errors… I am sure of it, but I can’t figure out why!

    Sorry, that last line should have read “Something is happeneing where nextgen is NOT referencing its sources…”

    I’m getting a problem- after using NextGen for a couple of years – can’t create new galleries.
    I guess I should check my other sites, too
    And see if I can add images to old galleries.

    OK. Removed the plug in…. deactivated ALL other plugins. Completely reinstalled the plug in and ALL of the problems persist. What the hell is going on here? PLEASE someone help. I made 8 galleries and the thing just falls apart? This doesn’t seem right.

    The issue has to be something with nextgen not knowing where its own files are. The 404 errors all over the place MUST mean something???? Why on earth would something that worked fine just stop working, and even a completely new download of the plugin and a reinstall cause the same problem?

    Try to access nextgen-gallery folder via HTTP, for example http://www.example.com/wp-content/plugins/nextgen-gallery/admin/upload.php

    Getting HTTP 404 error?

    If you have restricted HTTP access to the plugin folder + using mod_rewrite for permalinks, it may cause 404 error for restricted files or folders.

    Maybe try to place .htaccess file with following code to nextgen-gallery folder:

    <FilesMatch "upload.php">
        Allow from all
        Satisfy Any

    or simply

    Allow from all
    Satisfy Any

    I have moved on to another plug in. Thanks Honza108 for the info, it sounds like that might have helped. My access to the plugin folder might have been the issue, sounds like there was possibilities there. Unfortunately, I am using a different plug in and no longer have next gen gallery so I can’t test your idea.

    I am officially closing this topic. Thanks.

    what plug in did you decide to try? i am trying nextgen and having the same issues as you. just downloaded this week and created things from the beginning but have to upload pics one by one, etc. i would like to just try something else at this point.

    Honza108, trying your fix to this problem but without success. Thanks!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘nextgen gallery loses functionality’ is closed to new replies.