Support » Plugins » NextGen Gallery can’t upload

  • hello,
    i have problems uploading pictures to wordpress i’m using NextGen gallery.
    If i try to upload a picture i get the login page for a quick second and then the error: Directory /mounted-storage/home66a/sub003/sc39615-QKDA/mysite/wp-content/gallery/album contains no pictures

    some kind of permissions issue?


Viewing 15 replies - 1 through 15 (of 20 total)
  • I am having the same problem. I followed the README to the letter, 777 etc on the Gallery folder. I briefly saw a “302 HTTP” error still the individual image upload is not working, the zip upload and server folder work fine. server info I am using hostgator and currently installed WP version 2.3.2 (please update me soon fantastico) HELP!

    Posted too soon, I solved my problem. After un-checking the “Activate batch upload” in the Options tab everything works fine, I tried upgrading my flash player, same stuff. Oh using firefox, OSX 10.5.1 if that helps the developers.

    The zip doesn’t work for me, even after I disable batch upload. I get this error:

    Fatal error: Out of memory (allocated 7864320) (tried to allocate 86419572 bytes) in (blahblahblah)/wp-content/plugins/nextgen-gallery/lib/pclzip.lib.php on line 3952

    I have these settings:
    # PHP Version : 5.2.3
    # PHP Safe Mode : Off
    # PHP Allow URL fopen : Off
    # PHP Memory Limit : 90M
    # PHP Max Upload Size : 7M
    # PHP Max Post Size : 8M
    # PHP Max Script Execute Time : 30s

    90M for PHP memory limit should def be all set. I wish this was would – otherwise it’s perfect.

    what was the size of your zip? out of interest I found anything over 5MB didn’t work for me.. Little upsetting having to upload multiple zips. sorry I don’t have any real help.


    have the same problem on a local Windows XP installation, WordPress last release, NextGEN last release, imagerotator .swf file installed.
    I think it might be a problem, on Windows system, coming from the script trying to create a temporary upload folder somewhere without succeeding, so that then it cannot move the uploaded file to the definitive directory. But I can’t debug it easily. Has anybody some suggestions?


    The PHP memory error was fixed. One of the files was incorrect. Check the author’s plugin page for a new verson.

    I had this problem – wp2.5 & nextgen 0.94

    memory allocation error (blahblahblah)/wp-content/plugins/nextgen-gallery/lib/pclzip.lib.php on line 3952

    I fixed it by changing the line before (3951):

    $maxMemory = $memory_limit - memory_get_usage() - 350000;
    $maxMemory = $memory_limit - memory_get_usage() - 3500000;

    bascially, allocate less memory

    I have the same problem 🙁

    If you have memory problems with the zip upload, please replace the nextgen-gallery/lib/pclzip.lib.php with the original version from here :

    Sometimes my modifictation causes problems.

    i have problems to upload images (even a single one) if the batch upload is activated. is there any solution to solve this problem?

    please help 🙂

    p.s.: i’m using firefox on a mac.

    Check if you use the latest flash version and check also for javascript errors…

    hi alex,

    i’ve updated the flashplayer and tried again to upload 3 images with activated batch upload. no javascript errors, but at the end of each image (100%) the message:

    Ungültiger Upload. Fehler Code :1


    it seems that only the last image has been uploaded, because there is no error when it’s finished.


    Strange, dos it work under safari ?


    I have three websites where I am running WordPress with Nextgen, all the latest versions. Windows XP machines and Firefox. On two of the three I cannot upload pictures using the flash upload feature. It gives me a 403 error. I have no problems uploading zip files or via ftp. Settings seem to be the same on all three websites. I’ve tried changing the permissions, but that didn’t make a difference. I’ve read the above, but cannot find the ‘active batch upload’ checkbox anywhere. Anything in the ‘upload images’ section does not seem to work. Any suugestions are more than welcome. Thanks!


    i need access to you wordpress to check this, if interested please conact me by mail

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘NextGen Gallery can’t upload’ is closed to new replies.