Support » Plugin: Plugin Organizer » Nextgen Gallery Admin – Add Images

  • I just installed Nextgen Gallery, a popular plugin. Since I only want to show Nextgen images in certain posts, I included Nextgen as one of the plugins disabled under Global. I only want to enable it in posts where I need it.

    Selective Admin Plugin loading is OFF.

    So I am able to do all the admin stuff of Nextgen, except when trying to upload images, resulting in an http error.

    When I enable the plugin under Global (i.e. remove from Disabled list), no problem, uploading images is fine.

    Any ideas ?

    Thanks

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Jeff Sterup

    (@foomagoo)

    Create a plugin filter with your sites root URL as the permalink and enable Nextgen. It is probably submitting to your root URL rather than an admin URL.

    Thanks, Jeff,

    I did that and unfortunately it didn’t work …

    I saw this from your website :
    “Contact Form 7 is a good example of this. When you submit the form it does not submit to the page you are on. It submits to the wp-json url of wordpress. So you’ll need to add that url to the list of permalinks in your plugin filter. Or create a plugin filter for that url if you didn’t use the plugin filter method.”

    How can I find out which url Nextgen Add function is submitting to ?

    • This reply was modified 1 year, 6 months ago by astrasuite.
    Plugin Author Jeff Sterup

    (@foomagoo)

    Do you have ignore URL arguments enabled?

    Plugin Author Jeff Sterup

    (@foomagoo)

    Actually. I think you may have uncovered a bug. I just downloaded nextgen gallery and the plugin filter should be working. But it is not. Because my code is not ignoring the URL arguments for some reason. I will have to figure out what is going on and possibly release a fix.

    Plugin Author Jeff Sterup

    (@foomagoo)

    Ok. NM. I didn’t have my plugin filter set correctly. I forgot to enable Nextgen on the filter.

    First I disabled Nextgen globally. Then I created a plugin filter with the permalink set as http://www.jsterup.com/ and enabled Nextgen for all roles. Then I went into the Nextgen admin page and was able to add images.

    Hi, Jeff, yes, I have ignore URL arguments enabled. Is that right ?

    I will try that. Just to be sure, your image really got uploaded ? NGG has a message that upload was successful, even if it was not. If it was not, there is a yellow triangle icon that shows briefly.

    • This reply was modified 1 year, 6 months ago by astrasuite.
    Plugin Author Jeff Sterup

    (@foomagoo)

    Yes. The image was successfully uploaded.

    Just tried it, it doesn’t work still. I don’t have to enable by role, as I have “Disable Plugins by Role” off. My website is for example, abc.com. My wordpress is in abc.com/mywordpress/. I tried both in a plugin filter and no luck.

    Should I enable role ? But I really don’t need it as I am the only admin.

    My workaround for now is, when needed, to enable NGG globally and upload images, then disable again.

    Plugin Author Jeff Sterup

    (@foomagoo)

    So you created a filter with http://www.abc.com/mywordpress/ as the permalink and enabled Nextgen?

    Yes, as well as http://www.abc.com/

    Plugin Author Jeff Sterup

    (@foomagoo)

    Yes you should have ignore URL arguments enabled. I’m not sure what the problem is. It is working on my site.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Nextgen Gallery Admin – Add Images’ is closed to new replies.