Support » Plugins and Hacks » NextGEN Gallery Optimizer » NextGen Gallery 2.0…Oops

NextGen Gallery 2.0…Oops

  • Hi Mark,
    I acted too fast and upgraded to NextGen Gallery 2.0. After I did that, my five thumbnails in each row changed to 4 in a row to 1 in a row to 4 in a row, etc. I also noticed that I could not go from photo to photo in lightbox mode. Help? What should I do?

    I have been playing with the settings. Or, I really want the NextGen version before I updated so that I do not have to worry about this right now.

    Can you help?



Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Mark Jeldi


    Hi Carl,

    NextGEN 2.0 has a number of issues, and Optimizer (up to v1.1.2) is not yet compatible with its new framework, so rolling back to NextGEN v1.9.13 would indeed be best for the time being.

    You can find the download at the following link, and please remember to backup your database and “wp-content/gallery” folder before reverting (or updating in the future)…


    Also, here are some step by step instructions for reverting safely (DO NOT delete the plugin through your WordPress dashboard!)…


    I hope this helps!


    hey mark,

    hope you are fine! i also rolled back after update to 2.x sinde thumbnails created page error…

    you have any timeplan for the optimizer dealing good with nextgen 2.x?

    thx so much again

    I am getting this appearing

    instead of the images is this something I have done wrong or a problem with the plugin

    I just shows an option to view the slideshow and the url for the images


    Plugin Author Mark Jeldi


    Hey Fritz!

    I’m currently hard at work on Optimizer’s compatibility with NextGEN v2.0, though it’s difficult to say when it will be ready at this stage. The plugin has to be largely rewritten in order to hook into the completely new NextGEN v2.0 code base, whilst maintaining backwards compatibility for the many users either not upgrading or rolling back.

    It’s also proving difficult developing for NextGEN v2.0.x as it’s now based on a complicated (yet undocumented) framework, and has many issues, inconsistencies and unexpected behaviors. Hopefully things will improve with future updates, and that we have full compatibility soon.

    The error you were experiencing after updating sounds like it was actually from the gallery itself, so you may want to wait a bit anyway until at least the larger issues in NextGEN v2.0.x have been ironed out.

    All the best,

    Plugin Author Mark Jeldi


    Hi Minnie,

    Thanks for using NextGEN Gallery Optimizer!

    I’ve just had a look at your page, and you seem to have switched to the slideshow built into the Jetpack plugin rather than NextGEN Gallery. Is this correct?

    I’d be happy to look into this for you, but I’d need to see your page’s source code output when both NextGEN and Optimizer are activated in order to troubleshoot the issue.


    Hey Mark,
    thanks an keep us updated! Thanks for your support, again!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘NextGen Gallery 2.0…Oops’ is closed to new replies.
Skip to toolbar