Support » Plugin: WordPress Gallery Plugin - NextGEN Gallery » NextGen Galleries Stopped Working on Site

  • Resolved toddwhittle

    (@toddwhittle)



    Hello…

    We just realized that the NextGen galleries of our products have stopped working on our site. We were on WP ver 3.9.1, but thought the WP upgrade caused it, so I migrated us back to ver 3.8.1. No dice. Still not working. I DID notice that when I click on the gallery in the edit page, once the NextGen window opens, it prompts me to log in again, and that my session has expired.

    I know my galleries are in there, as I can see them. But when I’m asked which gallery to use, and then select “Sort or Exclude Images”, there is a message that says “No entries to display for this source”.

    Can anyone help me shed some light on this little booger?

    http://www.betterengineering.com/product/g-2000-series/

    Thanks!

    Todd

    https://wordpress.org/plugins/nextgen-gallery/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Oh, by the way – I’ve tried disabling all other plugins to see if there was a conflict, and it STILL didn’t work for me.

    Thanks!

    Plugin Author photocrati

    (@photocrati)

    @toddwhittle – I’m not sure why your sessions would be timing as you are describing them … I would look to the server environment for any settings that may have been changed or are not set correctly?

    As to the Sort/Exclude panel in the IGW, sometimes that can take a little while to generate the thumbnail images based on the choices made with the display’s source, but given you are seeing odd time-out issues the server may not be reporting the time-out while it works and NextGEN Gallery just leaves the default message you are seeing.

    What are the “Server Settings” you see under Gallery > Overview?

    – Cais.

    Operating System : Linux (32 Bit)
    Server : Apache
    Memory usage : 45.25 MByte
    MYSQL Version : 5.0.96-log
    SQL Mode : Not set
    PHP Version : 5.3.24
    PHP Safe Mode : Off
    PHP Allow URL fopen : On
    PHP Memory Limit : 268435456
    PHP Max Upload Size : 32M
    PHP Max Post Size : 33M
    PCRE Backtracking Limit : 1000000
    PHP Max Script Execute Time : 30s
    PHP Exif support : Yes ( V1.4 )
    PHP IPTC support : Yes
    PHP XML support : Yes
    Graphic Library

    GD Version : bundled (2.0.34 compatible)
    FreeType Support : Yes
    FreeType Linkage : with freetype
    T1Lib Support : No
    GIF Read Support : Yes
    GIF Create Support : Yes
    JPEG Support : Yes
    PNG Support : Yes
    WBMP Support : Yes
    XPM Support : No
    XBM Support : Yes
    JIS-mapped Japanese Font Support : No

    Plugin Author photocrati

    (@photocrati)

    @toddwhittle – I’m not seeing anything out of place in those setting … you might try bumping up the Max Execute Time to 60s and see if that helps with the time-out issues but generally 30s is enough.

    – Cais.

    How would I go about doing that, Cais…this is hosted by (cough cough) GoDaddy.

    Plugin Author photocrati

    (@photocrati)

    @toddwhittle – You could ask them for help (mostly to ensure the setting is honored), or you could try adding it yourself with a php.ini file added to or modified in the root of the installation (generally at the same level as /wp-admin/ and /wp-includes/).

    – Cais.

    Okay – chalk this up to experience, or lack thereof. So here’s what happened. The original WP site was set up to point to betterengineering.com rather than http://www.betterengineering.com. So they decided, in the advantage of SEO, to have me change it to http://www.betterengineering.com. Inside of WP, it would not take. So I researched and found to go into the wp-config file and change it with this code:

    define(‘WP_HOME’,’http://www.betterengineering.com’);
    define(‘WP_SITEURL’,’http://www.betterengineering.com’);

    THAT was when it stopped working. So tonight, after practically pulling my hair out and hanging myself, I thought of this, and decided to go and alter the wp-config BACK to it’s original state. It worked!

    So, lesson learned. We’re back to square one with better…versus http://www.better, but at least their site visitors can see the image galleries!!

    Thanks for the help provided, Cais. Really appreciate the help.

    Todd

    Plugin Author photocrati

    (@photocrati)

    @toddwhittle – Wow … well, I’m glad you sorted it out. Well Done!

    Also, now knowing you changed the URL used by the site, you may have been able to use the Reset Option under Gallery > Other Options and then clear the image cache under Gallery > Other Options > Miscellaneous … that might have also worked as this is very similar to a “migration” and the Reset Option helps to sort out issues similar in nature.

    – Cais.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘NextGen Galleries Stopped Working on Site’ is closed to new replies.