WordPress.org

Support

Support » Plugins and Hacks » Nextgen can’t find GD

Nextgen can’t find GD

  • I’m running WP 2.5 and i’ve installed NextGen 0.92.

    When i try and import image files (jpg), i get the following error message:

    You do not have the GD Library installed. This class requires the GD library to function properly. visit http://us2.php.net/manual/en/ref.image.php for more information

    GD is definitely installed on the server.

    From phpinfo:

    gd
    GD Support enabled
    GD Version 2.0 or higher
    FreeType Support enabled
    FreeType Linkage with TTF library
    FreeType Version 1.3
    GIF Read Support enabled
    GIF Create Support enabled
    JPG Support enabled
    PNG Support enabled
    WBMP Support enabled

    Can anyone suggest what might be wrong? Or suggest where to start looking?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Moderator Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    That bit of code happens with this:
    if(!function_exists("gd_info")) {

    So, apparently, something is wrong with the installation since PHP is reporting that the gd_info function does not exist.

    Hmmm… Thanks for that.

    Running this script:

    <?php
    var_dump(gd_info());
    ?>
    
    <p>check if function exists</p>
    
    <?php
    if(function_exists("gd_info")) {
            echo "function exists";
    }

    gives this output:

    array(12) { [“GD Version”]=> string(13) “2.0 or higher” [“FreeType Support”]=> bool(true) [“FreeType Linkage”]=> string(16) “with TTF library” [“T1Lib Support”]=> bool(false) [“GIF Read Support”]=> bool(true) [“GIF Create Support”]=> bool(true) [“JPG Support”]=> bool(true) [“PNG Support”]=> bool(true) [“WBMP Support”]=> bool(true) [“XPM Support”]=> bool(false) [“XBM Support”]=> bool(false) [“JIS-mapped Japanese Font Support”]=> bool(false) }

    check if function exists
    function exists

    That suggested to me that the gd_info function does exist and that running it gives some output.

    So… I commented out that test in thumbnail.inc.php – and it works.

    I’m only just starting to learn about php, so i’m a bit confused. Any idea what’s going on here?

    Same problem here. GD and curl are installed and showing up in phpinfo queries, however nextgen and slickr cant see them. I’ve repeatedly tried deactivating and activating the plugins, even deleted and re-FTP’d.

    I ran into a post saying that adding extension=php_curl.dll
    to the php.ini worked, but it did nothing for me.

    Any ideas how to slap the GD query into behaving sensibly?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Nextgen can’t find GD’ is closed to new replies.